[SOLVED] Port 25 does not work on the node PMG

PSG

New Member
Nov 6, 2019
3
0
1
Germany
Good morning everyone,

I am not sure whether this post is correctly created under "Mail Gateway: HA Cluster". If not, please move it.

I'm still relatively new to using the PMG. I already have a PMG in productive use and it works fine. Now I have set up another PMG in parallel to use it as a cluster node for failover. Now I have the following problem: On the master port 25 and port 26 work as they should. Unfortunately only port 26 works on the node.

I have tested this as follows from a PC within the "internal" network:

1)
telnet Master_IP 25
--> 220 FQDN_Master ESMTP Proxmox

openssl s_client -connect Master_IP:25 -starttls smtp
--> The communication works and the available certificates are displayed.

2)
telnet Master_IP 26
--> 220 FQDN_Master ESMTP Proxmox

openssl s_client -connect Master_IP:26 -starttls smtp
--> The communication works and the available certificates are displayed.

3)
telnet Node_IP 25
--> The connection is established, but there is no response from the PMG. The Telnet window remains black.

openssl s_client -connect Node_IP:25 -starttls smtp
--> CONNECTED(0000011C).
More does not appear here !

4)
telnet Node_IP 26
--> 220 FQDN_Node ESMTP Proxmox

openssl s_client -connect Node_IP:25 -starttls smtp
--> The communication works and the available certificates are displayed.

Has anybody ever had this phenomenon and what shoud I do ?

Thanks for a few tips.

WHICH Mail Gateway Version do you use? We are using Mail Gateway 6.2-5
WHICH License type do you use? Community Subscription
WHICH Hardware do you run? VMware ESXi (HA) on multiple Servers / Datastore on a HA SAN storage

Cheers !
Toby
 
Last edited:

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,896
804
148
on a hunch - could you try to run:
* pmgconfig sync -restart 1
* reboot the node afterwards

then try the connection tests again
if this does not fix the issue - take a look at the logs: `journalctl -f` ( let it run while trying to connect with netcat/openssl)

I hope this helps!
 

PSG

New Member
Nov 6, 2019
3
0
1
Germany
Hi Stoiko,

thanks for your reply. The problem has been solved. Firstly, I noticed that the node server's spamassassassin cloud not connect to the internet via port 2703 and that a file called dnsbl_reply was missing. After I fixed these two issues, the node worked on port 25.

I was helped by your tip with `journalctl -f`. Thanks a lot.

Cheers
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
5,896
804
148
thanks for your reply. The problem has been solved. Firstly, I noticed that the node server's spamassassassin cloud not connect to the internet via port 2703 and that a file called dnsbl_reply was missing. After I fixed these two issues, the node worked on port 25.
hm - 2703 would only be needed for razor support - but I guess if you've enabled that then pmg-smtp-filter might exit with an error - that should still leave postfix answering to the STARTTLS request

but in any case - glad you resolved your problem - please mark the thread as 'SOLVED'

Thanks!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!