No internet access as LACP bond

bulowaty

New Member
Jun 4, 2020
3
0
1
33
Hello,
I would like to ask for help.
I have Dell server with installed latest version of Proxmox VE and Cisco infrastructure.
I want to do LACP bonding between both ethernet interfaces.

I have ports on switch configured in this way:
Code:
interface Port-channel3
description SERVER
switchport mode trunk
lacp max-bundle 2
!
interface GigabitEthernet1/0/43
switchport trunk native vlan 601
switchport mode trunk
channel-protocol lacp
channel-group 3 mode active
!
interface GigabitEthernet1/0/44
switchport trunk native vlan 601
switchport mode trunk
channel-protocol lacp
channel-group 3 mode active
!

and /etc/network/interfaces looks like that
Code:
auto lo
iface lo inet loopback

auto eno3
iface eno3 inet manual

auto eno4
iface eno4 inet manual

auto bond0
iface bond0 inet manual
    bond_slaves eno3 eno4
    bond_miimon 100
    bond_mode 802.3ad
    bond_xmit_hash_policy layer2+3
   
auto vmbr0
iface vmbr0 inet static
    address 192.168.60.11
    netmask 255.255.255.128
    gateway 192.168.60.1
    bridge_ports bond0
    bridge_stp off
    bridge_fd 0
    bridge_vlan_aware yes
    bridge_vids 2-4094

iface eno1 inet manual

iface eno2 inet manual

The problem is that proxmox says the links are up, but on switch there are down so I have no internet access to the host.
Could you please let me know how to configure LACP between Cisco switches and Proxmox correctly?
I tried to use proxmox wiki, but there is bond0 on static mode so it requre to add address variable.

Ps. the machine has not internet access so I cannot install any other soft like ifenslave, ifconfig or openvswitch.
[edit] on switch ports are enabled but link is down

Thanks for help, regards Robert
 
Code:
interface Port-channel3
 description SERVER
 switchport trunk native vlan 601
 switchport mode trunk
 spanning-tree portfast disable
 lacp max-bundle 2
!
This is the solution. I forgot to put native vlan 601 on port-channel settings in switch. Thanks for reply! :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!