Sorry for this pure Cisco Q here, have also posted to Cisco forum, but maybe anyone here knows better/faster.
I'm new to Cisco IOS/NxOS, have two 5672UP I want to stack in a vPC domain so I can have 2x ports w/lacp for teaming/bonding PVE hosts.
Only I seem not to get neither load bal. nor redundancy to work, just traffic through secondary switch.
Also I would like to tag any untagged packets ingress/egress on Ethernet 1/1-2 from/to a HP MSA box.
Hints and/or pointers are appreciated, TIA!
Both N5Ks are configured the same. Should it be possible to configure things only once on primary after in sync on peer-links like w/Juniper vChassises?
Some info, let me know if more are needed:
leaf01.fab01# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 0
Peer Gateway : Enabled
Peer gateway excluded VLANs : -
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 up 1-100
leaf02.fab01# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary
Number of vPCs configured : 0
Peer Gateway : Enabled
Peer gateway excluded VLANs : -
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 up 1-100
leaf01.fab01# show run
...
vlan 1-19
vlan 20
name msaA
vlan 21
name msaB
vlan 22-100
vrf context management
ip route 0.0.0.0/0 1.1.1.2
vpc domain 100
peer-switch
role priority 2000
system-priority 2000
peer-keepalive destination 1.1.1.2 source 1.1.1.1
delay restore 150
peer-gateway
ip arp synchronize
port-profile type ethernet pve-node
switchport mode trunk
speed 10000
duplex full
switchport trunk allowed vlan 2-100
state enabled
interface port-channel1
description PortChannel for n1.pve
switchport mode trunk
switchport trunk allowed vlan 2-100
speed 10000
duplex full
interface port-channel2
description PortChannel for n2.pve
switchport mode trunk
switchport trunk allowed vlan 2-100
speed 10000
duplex full
...
interface port-channel100
description vPC peer-link
switchport mode trunk
spanning-tree port type network
vpc peer-link
interface Ethernet1/1
inherit port-profile pve-node
description HP MSA ctrl A port 1
switchport trunk native vlan 20
switchport trunk allowed vlan 20
interface Ethernet1/2
inherit port-profile pve-node
description HP MSA ctrl B port 1
switchport trunk native vlan 21
switchport trunk allowed vlan 21
interface Ethernet1/3
inherit port-profile pve-node
description "n1.pve eth9"
channel-group 1 mode active
interface Ethernet1/4
inherit port-profile pve-node
description "n2.pve eth9"
channel-group 2 mode active
...
interface Ethernet2/5
description vPC peer-link to leaf02 2/5
switchport mode trunk
spanning-tree port type network
channel-group 100
interface Ethernet2/6
description vPC peer-link to leaf02 2/6
switchport mode trunk
spanning-tree port type network
channel-group 100
interface mgmt0
vrf member management
no ip redirects
ip address 1.1.1.1/24
line console
line vty
boot kickstart bootflash:/n6000-uk9-kickstart.7.2.0.N1.1.bin
boot system bootflash:/n6000-uk9.7.2.0.N1.1.bin
poap transit
I'm new to Cisco IOS/NxOS, have two 5672UP I want to stack in a vPC domain so I can have 2x ports w/lacp for teaming/bonding PVE hosts.
Only I seem not to get neither load bal. nor redundancy to work, just traffic through secondary switch.
Also I would like to tag any untagged packets ingress/egress on Ethernet 1/1-2 from/to a HP MSA box.
Hints and/or pointers are appreciated, TIA!
Both N5Ks are configured the same. Should it be possible to configure things only once on primary after in sync on peer-links like w/Juniper vChassises?
Some info, let me know if more are needed:
leaf01.fab01# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 0
Peer Gateway : Enabled
Peer gateway excluded VLANs : -
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 up 1-100
leaf02.fab01# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
vPC domain id : 100
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary
Number of vPCs configured : 0
Peer Gateway : Enabled
Peer gateway excluded VLANs : -
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Enabled (timeout = 240 seconds)
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 up 1-100
leaf01.fab01# show run
...
vlan 1-19
vlan 20
name msaA
vlan 21
name msaB
vlan 22-100
vrf context management
ip route 0.0.0.0/0 1.1.1.2
vpc domain 100
peer-switch
role priority 2000
system-priority 2000
peer-keepalive destination 1.1.1.2 source 1.1.1.1
delay restore 150
peer-gateway
ip arp synchronize
port-profile type ethernet pve-node
switchport mode trunk
speed 10000
duplex full
switchport trunk allowed vlan 2-100
state enabled
interface port-channel1
description PortChannel for n1.pve
switchport mode trunk
switchport trunk allowed vlan 2-100
speed 10000
duplex full
interface port-channel2
description PortChannel for n2.pve
switchport mode trunk
switchport trunk allowed vlan 2-100
speed 10000
duplex full
...
interface port-channel100
description vPC peer-link
switchport mode trunk
spanning-tree port type network
vpc peer-link
interface Ethernet1/1
inherit port-profile pve-node
description HP MSA ctrl A port 1
switchport trunk native vlan 20
switchport trunk allowed vlan 20
interface Ethernet1/2
inherit port-profile pve-node
description HP MSA ctrl B port 1
switchport trunk native vlan 21
switchport trunk allowed vlan 21
interface Ethernet1/3
inherit port-profile pve-node
description "n1.pve eth9"
channel-group 1 mode active
interface Ethernet1/4
inherit port-profile pve-node
description "n2.pve eth9"
channel-group 2 mode active
...
interface Ethernet2/5
description vPC peer-link to leaf02 2/5
switchport mode trunk
spanning-tree port type network
channel-group 100
interface Ethernet2/6
description vPC peer-link to leaf02 2/6
switchport mode trunk
spanning-tree port type network
channel-group 100
interface mgmt0
vrf member management
no ip redirects
ip address 1.1.1.1/24
line console
line vty
boot kickstart bootflash:/n6000-uk9-kickstart.7.2.0.N1.1.bin
boot system bootflash:/n6000-uk9.7.2.0.N1.1.bin
poap transit