exclude disk from qemu backup on Proxmox 4

malakatronis

Active Member
Jul 21, 2012
36
0
26
Spain
Hello,

I have a qemu VM configured not to backup one of its two virtual disks, i.e., "backup=0" is set in its configuration file. I think the vzdump command doesn't honor the disk exclusions since the last Proxmox update.

/etc/pve/qemu-server/1254.conf:
sata0: local:1254/vm-1254-disk-1.qcow2,size=64424509440
sata1: local:1254/vm-1254-disk-2.qcow2,backup=0,size=214748364800

Yesterday it was working as expected:

NFO: Starting Backup of VM 1254 (qemu)
INFO: status = running
INFO: update VM 1254: -lock backup
INFO: exclude disk 'sata1' (backup=no)
INFO: backup mode: snapshot
INFO: ionice priority: 7

But today it doesn't seem to read the setting:

INFO: Starting Backup of VM 1254 (qemu)
INFO: status = running
INFO: update VM 1254: -lock backup
INFO: backup mode: snapshot
INFO: ionice priority: 7

(The corresponding line is missing from the excerpt and the backup file does contain all the disks.)

Does this happen to any of you? Am I missing something? Maybe the backup command behaviour has changed and I failed to learn about it?

root@malakatronis:~# pveversion -v
proxmox-ve: 4.1-34 (running kernel: 4.2.6-1-pve)
pve-manager: 4.1-5 (running version: 4.1-5/f910ef5c)
pve-kernel-4.2.6-1-pve: 4.2.6-34
pve-kernel-4.2.2-1-pve: 4.2.2-16
pve-kernel-4.2.3-2-pve: 4.2.3-22
lvm2: 2.02.116-pve2
corosync-pve: 2.3.5-2
libqb0: 0.17.2-1
pve-cluster: 4.0-31
qemu-server: 4.0-49
pve-firmware: 1.1-7
libpve-common-perl: 4.0-45
libpve-access-control: 4.0-11
libpve-storage-perl: 4.0-38
pve-libspice-server1: 0.12.5-2
vncterm: 1.2-1
pve-qemu-kvm: 2.5-3
pve-container: 1.0-39
pve-firewall: 2.0-15
pve-ha-manager: 1.0-19
ksm-control-daemon: 1.2-1
glusterfs-client: 3.5.2-2+deb8u1
lxc-pve: 1.1.5-6
lxcfs: 0.13-pve3
cgmanager: 0.39-pve1
criu: 1.6.0-1
 

ropiecin

Member
May 7, 2015
9
0
21
unfortunatelly I have same issue!
I have had to disable all my backups!

please:
what is the estimated time for the solution?
how can you know when the problem will be solved?
Is a workaround available?
 

swap_file

New Member
Jan 31, 2016
2
0
1
38
Same here, does anyone know the steps to downgrade to fix this problem, or timeline on a fix?

I had to disable all of my backups too, which is a major problem.
 

swap_file

New Member
Jan 31, 2016
2
0
1
38
It looks like the problem was fixed 2 days ago in qemu-server 4.0-51

https://github.com/proxmox/qemu-server/commits/master

The fix isn't on the pve-no-subscription repository yet, but it is on the pvetest repository (use at your own risk).

It seems to have fixed it for me, I'm seeing the correct excluded disk message, but the backup won't be done for an hour or two.
 

malakatronis

Active Member
Jul 21, 2012
36
0
26
Spain
I confirm the issue is fixed in qemu-server (4.0-51) which was released today on the pve-no-subscription repository.

Thanks!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!