Recent content by The Corpse of Elvis

  1. How do I restore or recreate a CT using an exisitng subvol (on ZFS)?

    It's the root disk. FYI, the old subvols that I want to restore are on "nvme-pool", and my new container subvols are in "rpool/data". I have just tried the following procedure- I used syncoid to send | recv subvol-101-disk-0 from "nvme-pool" to "rpool/data". I renamed the...
  2. I've really screwed up bad, PLEASE HELP!

    I am aware of that but thank you for mentioning it. If the "sent" was within a string I had formatted as inline code, then it was a (now fixed) typo. I think at this point, I need to clarify that there are two main issues, so to speak. First of all, I may or may not have destroyed my old...
  3. I've really screwed up bad, PLEASE HELP!

    That's weird. So you can't see https://forum.proxmox.com/threads/ive-really-screwed-up-bad-please-help.91408/#post-399582 ? I can see it whilst I'm logged in but not when I open a new private browser window. If anyone could enlighten me as to why it was deleted, I'd be grateful. Anyway...
  4. I've really screwed up bad, PLEASE HELP!

    Thank you for your response. Before you posted, I had started editing my previous comment with info regarding use of the -R flag. Please see the edit at the bottom of my previous comment for more details.
  5. I've really screwed up bad, PLEASE HELP!

    I just don't understand what's going on... I've booted my FreeNAS / TrueNAS install and imported the nvme-pool. I've then taken a recursive snapshot of the nvme-pool via the TrueNAS GUI, and then send | recv'd via the shell to a newly create pool (pool980). When I navigate pool980, the dataset...
  6. I've really screwed up bad, PLEASE HELP!

    There's good new and bad news.... The good news is, is that I've got a second NVMe disk and I'm ready to sort out a mirrored boot disk. The bad news is that in the process of send | recv a snapshot of nvme-pool to my rpool disk, I think I've found the reasons why my data disappeared on my...
  7. Can't use LXC snapshots while a Bind Mount is setup

    I would love to be able to snapshot Containers that have bind mounts without having the edit the .conf each time!
  8. I've really screwed up bad, PLEASE HELP!

    For what it's worth, I've attached the old install disk to my PC and imported the pool as altrpool. I then ran sudo zfs list -r altrpool. NAME USED AVAIL REFER MOUNTPOINT altrpool 30.7G 198G 104K /altrpool altrpool/ROOT...
  9. I've really screwed up bad, PLEASE HELP!

    That's what I've done, both with an Ubuntu live CD and from a fresh install of Proxmox (on a different disk) but the snapshots are all small (see the second post of this thread) and the boot behaviour remains the same.
  10. I've really screwed up bad, PLEASE HELP!

    1. I hear ya... that's why the really important stuff on TANK is almost entirely backed up to another ZFS pool on a TrueNAS server, which has been off for a couple of weeks (so I should have 99.9% of the data elsewhere). But this is definitely a lesson learned, I had been planning to replicate...
  11. I've really screwed up bad, PLEASE HELP!

    When I rollback, the boot behaviour is the same as it was before I rolled back anything. The boot stalls and I get run-init: can't execute '/sbin/init': No such file or directory which causes a kernel panic. I think I'm just gonna fresh install. It'll get me back up and running quicker.
  12. How do I restore or recreate a CT using an exisitng subvol (on ZFS)?

    After doing something very stupid that looks like it may have destroyed my install, it looks like I might have to do a fresh install and create my containers from scratch. I still have the ZFS dataset subvols for the containers from my old, borked Proxmox install (as they were stored on a...
  13. I've really screwed up bad, PLEASE HELP!

    One last comment before I turn in. I'm at the point now where I'm starting to feel that perhaps I should take this as a blessing in disguise. (fingers crossed) I don't think I've lost anything really important... aside from the time I put into setting up my orignal install (smartd, crontab...
  14. I've really screwed up bad, PLEASE HELP!

    I'm starting to think that I've completely borked my install... I had a spare SSD laying around, so I did a fresh install of Proxmox onto "Fresh-SSD", and then tried importing my pools. Thankfully though, it appears my data on `TANK` and `nvme-pool` is intact. So I still have the important...
  15. I've really screwed up bad, PLEASE HELP!

    I have three ZFS pools on my server "TANK" - a 6x10TB RAIDz2 for my data "nvme-pool" - a single 500GB NVMe disk used for fast storage for LXC and VMs. Then there's the disk which Proxmox is installed to but I'm not 100% sure whether I should be calling it rpool or bpool, or something else, so...

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!