Recent content by naisanza

  1. OpenLDAP msg=SSL connect attempt failed

    Without "secure 1" it would be clear text. The auto-TLS would just be set to off
  2. grub with problem

    I see. Is there a documented method for reinstalling grub for Proxmox? What do we need to do with the BIOS boot and EFI System partitions? root@world:~# fdisk -l /dev/sdo Disk /dev/sdo: 37.3 GiB, 40020664320 bytes, 78165360 sectors Units: sectors of 1 * 512 = 512 bytes Sector size...
  3. grub with problem

    The scenario is that Proxmox is not able to boot. Proxmox had been installed and working prior to it no longer working. And upon following https://pve.proxmox.com/wiki/Recover_From_Grub_Failure You get the following issues: - unable to mount /dev/sdX1, because it is unable to determine the...
  4. grub with problem

    If you test it and run "grub-install /dev/sda" you'll see that it'll result in taking up 9.3MB Unless there are other grub-install options or pre-requisites that are required. So far, the issues are: - unable to mount /dev/sdX1, because it is unable to determine the fs/magicblock/etc. - you...
  5. grub with problem

    I don't have the error output with me, but when following the grub recovery page: https://pve.proxmox.com/wiki/Recover_From_Grub_Failure I get an error that it is not able to mount /dev/<proxmox>1 because it "can't find the magic block" or "doesn't know what fs it is"
  6. grub with problem

    This happens because Proxmox creates three partitions on a drive: 1. a 1MB BIOS boot partition 2. a 256MB EFI partition 3. the rest The BIOS boot partition is too small for grub to be installed into, which is why it complains there is no space left Grub needs at least 9.3MB to install
  7. OpenLDAP msg=SSL connect attempt failed

    Does anyone else use OpenLDAP with proxmox?
  8. OpenLDAP msg=SSL connect attempt failed

    I followed the steps enabling SSL for LDAP with a self-signed certificate, but get the error: Aug 10 05:15:56 world pvedaemon[515]: authentication failure; rhost=10.10.10.225 user=test2@ldap msg=SSL connect attempt failed https://help.ubuntu.com/lts/serverguide/openldap-server.html#openldap-tls...
  9. Timeout error at ISO Upload

    Uploading a 3.2GB ISO times out and gives and error Similar to this post, https://forum.proxmox.com/threads/timeout-error-at-iso-upload.8848/
  10. Portable Proxmox

    What are all of Proxmox's required directories? I'm looking to be able to put in a fresh install of Proxmox, and have Proxmox running by having all of its required settings, configurations, logons, and certificates stored in the ZFS pool I have "images", "templates", "containers", and...
  11. OpenVPN no longer needs lxc.cgroup.devices.allow and lxc.hook.autodev

    Unless it changed when the server was turned off for maintenance and back on again. I don't know what changed. Everything is vanilla on the server with zero system-wide changes, except for the container config in /etc/pve/lxc/<container>.conf Where can you find the global LXC policies?
  12. OpenVPN no longer needs lxc.cgroup.devices.allow and lxc.hook.autodev

    Upon 2 nights and 14 hours of troubleshooting later, it turns out Proxmox 4.4-1/eb2d6f1e no longer needs the following lines of code inside /etc/pve/lxc/<container>.conf lxc.cgroup.devices.allow = c 10:200 rwm lxc.hook.autodev = sh -c "modprobe tun; cd ${LXC_ROOTFS_MOUNT}/dev; mkdir net; mknod...
  13. [SOLVED] PVE v4.4 OpenVPN apparmor DENIED

    Did you add the lines to /etc/pve/lxc/<container>.conf? Did you create it as a Privileged Container? I think you can add it to the container.conf in either of the ways below (either with a "=" or a ":") and both ways still creates a /var/lib/lxc/container/config that works...
  14. [SOLVED] PVE v4.4 OpenVPN apparmor DENIED

    The apparmor error does not seem to affect running OpenVPN. the service is able to run and create a listening socket
  15. [SOLVED] PVE v4.4 OpenVPN apparmor DENIED

    PVE: 4.4 Image: Ubuntu 16.10 I'm following the tutorial for setting up OpenVPN, here: https://hungred.com/how-to/setup-openvpn-on-proxmox-lxc/. This worked just fine in PVE 4.2, and have set up 3 OpenVPN servers this way, but it no loger seems to work in PVE 4.4 I've added to...

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!