Recent content by Eddy Buhler

  1. E

    pvemailforward[1856827]: mail forward failed: user 'root@pam' does not have a email address

    Thanks, that is at least partially helpful, however, since mails are getting bounced and not getting out (this applies to mails sent to the address configured for the root@pam user...), I'd like to receive the bounce reply on the local root account. I can't just set "root" as the email address...
  2. E

    pvemailforward[1856827]: mail forward failed: user 'root@pam' does not have a email address

    I'm trying to configure email in Proxmox. For some reason, my recipient mail server bounces the mail, and I'd like to see the reason...however, Proxmox appears to not forward this to the local root account correctly with this message: pvemailforward[1856827]: mail forward failed: user...
  3. E

    [SOLVED] ceph atrocious performance inside LXC/VM

    I'm marking this solved, as the original issue stems mostly from a misconception on my part.
  4. E

    [SOLVED] ceph atrocious performance inside LXC/VM

    I did. I created pools with PG settings from 32 all the way up to 1024, and rados gave me the most comfortable performance mix out of them all at 128 PGs. I also experimented with splitting the drives up into four logical OSDs each, but that led to the ceph cluster showing degraded PGs...
  5. E

    [SOLVED] ceph atrocious performance inside LXC/VM

    Okay, so if I have write requests that queue up several write requests (iodepth=16 would queue up 16 4K blocks for writing to disk), I get the higher speed - at iodepth=16, I do get ~80MB/s, from inside LXC. But a single threaded app writing 4K blocks one at a time (such as dd with bs=4K) would...
  6. E

    [SOLVED] ceph atrocious performance inside LXC/VM

    Sure: # smartctl -a /dev/nvme0n1 smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.11.22-3-pve] (local build) Copyright (C) 2002-20, Bruce Allen, Christian Franke, www.smartmontools.org === START OF INFORMATION SECTION === Model Number: SAMSUNG MZQL23T8HCLS-00A07 Serial...
  7. E

    Random reboots on disk load

    If it doesn't help, try running # hdparm -tT --direct /dev/nvme*n1 and/or do dd writes to all the drives - I've had some drives on some servers be slow, and not all of it was PCIe settings - I actually had a faulty drive, too. All in all....make sure you check the hardware thoroughly with...
  8. E

    [SOLVED] ceph atrocious performance inside LXC/VM

    Well, I'd expect dd to show too high values if things were cached, but in this case, I am seeing much too low throughput, and I don't see how dd might be "obscurely slow" here. Anyway, here you go, this is from inside an LXC container: # fio --name=test.data --ioengine=libaio --rw=randwrite...
  9. E

    Random reboots on disk load

    Ok, I meant doing the stress test on the host, so all actual CPU cores get stresstested. I am not sure which PCIe-Settings the support was setting, but I expect it might have been the GEN settings (didn't ask for a KVM to check myself). Try setting that to a fixed value, and in doubt, set it...
  10. E

    Random reboots on disk load

    I assume this is a Hetzner AX101; the specs look familiar. Get in touch with tech support, have them check the PCIe BIOS settings. You'll get lower throughput on the drives (in my case, 2.7GB/s instead of around 3.5GB/s), but the drives will be stable. Also, possibly do a CPU stress test (I had...
  11. E

    [SOLVED] ceph atrocious performance inside LXC/VM

    I have set up a three note Proxmox cluster with ceph and a pool (size 3, min_size 2) for testing. OSDs are two NVMe disks on each server with a capacity of 3.5TiB each. ceph has one 10G network connection each for public and private network. The public network is also the LAN bridge for my VMs...
  12. E

    ceph degraded errors (new install)

    ceph -s was okay, but one of the servers just did a spontaneous reboot....looks like the CPU is throwing errors, so I'll check back and redo my tests/benchmarks once the hardware has been swapped out. I wish this had happened a week ago, it would have saved me a week of looking for problems in...
  13. E

    ceph degraded errors (new install)

    Hi, I'm in the process of setting up a new cluster with 3 nodes. The nodes have a pair of 3.5 TiB NVMe disks each that I use for ceph. I've split them into four logical osds each through ceph-volume lvm batch --bluestore --osds-per-device=4 /dev/nvme0n1 /dev/nvme1n1 so I have eight OSDs per...
  14. E

    vzdump: rbd: sysfs write failed ?

    Yeah, local storage is not an option for me, unfortunately.