Recent content by David Fisher

  1. D

    Accidentally deleted /etc/pve - and I don't have a backup

    I accidentally deleted /etc/pve and I have no backup. Can anyone guide me in getting up and running again? The disk image files are still in place and I have copies of vm conf files from /etc/pve/nodes/proxmox/qemu-server. But apart from that I have nothing. Re-installing would be a major pain...
  2. D

    Copy of proxmox datastore is much larger than original.

    I would but I was in a rush and I know rsync better. Plus I don't find proxmox docs very thorough or with clear useful examples.
  3. D

    Copy of proxmox datastore is much larger than original.

    Ah okay, thanks. I guess this explains it. What about restoring? Will I need the sparse flag then? The source disk is failing and will be replaced soon, so I'll be copying the backup to the new drive.
  4. D

    Copy of proxmox datastore is much larger than original.

    I have created a datastore on a 2TB disk, /dev/sdb. Filesystem Size Used Avail Use% Mounted on /dev/sdb1 1.8T 947G 794G 55% /datastore As you can see only 947G is used so far. Now I have a logical volume 1.4TB mounted on /backup and I'm using rsync to...
  5. D

    How to recover Proxmox from bare metal?

    I'm currently running Proxmox 5.4.3 standalone. Is there a guide anywhere that can tell me how I can restore my system in the event of a catastrophic disk failure? Starting with inserting a new disk and installing Proxmox, how do I then proceed to restore my VM's back to their original state...
  6. D

    Can no longer access proxmox web console correctly

    Update: Although I did try out the instructions in the section you are referring to, it did not appear to work. Now I see, this is just a browser problem. Doesn't work in Chrome, does work in IE and Firefox.
  7. D

    Can no longer access proxmox web console correctly

    Yes I saw that link, but right now I'm not bothered about getting my certificates to work. I just want to get back to the default configuration and I can worry about my certificates some other time.
  8. D

    Can no longer access proxmox web console correctly

    I was fiddling with the certificates and keys on my proxmox server, and gotten myself into an awful mess. I can no longer access the console of any vm's nor can I easily access the web console. I wanted to use my own certificates, so I replaced the following files with my own copies that I had...
  9. D

    Proxmox full clone will not boot: A disk read error occurred

    Just to add to this - I just started over creating another Win 2008 R2 machine and even if I dont convert to template first and simply clone, the clone will not boot. Looks like some problem using raw disk format on Win 2008 R2
  10. D

    Proxmox full clone will not boot: A disk read error occurred

    Something else interesting I noted. If I run 'file' against the clone image: root@proxmox:/datastore/images/104# file base-104-disk-1.raw base-104-disk-1.raw: DOS/MBR boot sector MS-MBR Windows 7 english at offset 0x163 "Invalid partition table" at offset 0x17b "Error loading operating system"...
  11. D

    Proxmox full clone will not boot: A disk read error occurred

    root@proxmox:/etc# pveversion -v proxmox-ve: 4.3-66 (running kernel: 4.4.19-1-pve) pve-manager: 4.3-1 (running version: 4.3-1/e7cdc165) pve-kernel-4.4.19-1-pve: 4.4.19-66 lvm2: 2.02.116-pve3 corosync-pve: 2.4.0-1 libqb0: 1.0-1 pve-cluster: 4.0-46 qemu-server: 4.0-88 pve-firmware: 1.1-9...
  12. D

    Proxmox full clone will not boot: A disk read error occurred

    I created a virtual machine in Proxmox which was Windows Server 2008 R2 using a raw disk format. After installing, running updates etc & configuring the VM, I converted it into a template. Now every time I create a full clone from this template the resulting VM will not boot. All I'm getting...