Recent security findings and fixes in Ceph make it necessary to upgrade ceph and migrate authentication keys from the aes to the aes256k cipher. This is to address weaknesses in the old Cephx authentication method, especially if your Ceph service...
IOW, the browser-local settings are stored in the browser's local storage. That is, if you clear the particular node's site data in the browser, the setting will be restored to the default value "auto".
There is no configuration file on the...
Hi!
The noVNC Settings Scaling Mode is a browser-local setting. FWIW, all settings in the "My Settings" panel are browser-local settings and aren't shared across different cluster nodes or browsers, so these are settings only for the current...
hi,
at the moment there is no option to weigh CPU load balancing higher than memory usage balancing.
feel free to file a feature request on bugzilla [0]
[0] https://bugzilla.proxmox.com/
This should be the same for VMs and CTs as the HA Manager handles affinity rules the same for both. In a quick test, the migration blocker with the same node affinity rule as above was shown to me for both VMs and CTs, so I couldn't move either...
It should not let you migrate neither the CT nor the VM. If it did, once you migrate a VM from pve-4 to pve-2, in the next ha cycle (~10 seconds) HA would say "this VM on pve-2 has another node with higher priority and the node is up, let's...
one thing to keep in mind about what causes imbalance and why migrations might not be effective is that non-HA-managed VMs contribute to imbalance too, but other than HA-managed resources they cannot be moved around to reduce imbalance
your...
This comment in BZ 7260 [0] does state how HA resources can be added by adding items to the existing HA resources list of the node affinity rule.
However, is there a specific use case why this is done in the pre-start hook-script instead of the...
We are excited to announce the first release of Proxmox Virtual Environment with official support for a second CPU architecture: 64-bit ARM (arm64/aarch64). Until now, Proxmox VE was available for x86-64 (amd64) only.
Proxmox VE 9.2 for arm64...
Hi!
This would be the expected behavior if there are no and have never been any active HA resource present (i.e. running) in the cluster. The CRM will only transition into an active state as soon as there are any active HA resource present, the...
Yes, to be exact rebalance-on-start will only be relevant if the HA resource goes through the request_start state, which can only happen if the HA resource was previously in the stopped state and e.g. a user requests the guest to be started...
Hi!
In case of a fenced node, the HA resources on the fenced node are put in recovery state and the HA Manager will select a recovery node for each HA resource individually. This will always try to spread the HA resources on the remaining...
Generally, these sound like good ideas! Feel free to create separate Bugzilla entries for the separate issues:
automatically add new guests as HA resources by enabling some cluster-wide check (Though new guests can be automatically added...
Hi Jonas!
Good catch! There is a patch for this already on the mailing list [0], I will send a new revision soon so this gets resolved!
This does only happen with the "migrate" shutdown policy and is documented in the documentation for the HA...
If a system needs high availability, there must be enough redundant hardware to compensate such node failures across the cluster. How many cluster node failures should be compensated is a question of cluster size (i.e. what is possible with...
Hi!
The section you're referring to states that the rebalance on start feature is in technology preview, not the CRS load balancer. The technology preview status for the CRS load balancer has been removed recently. But you are right, that the...
To clarify this here, this is the expected behavior for the given HA affinity rule set. Essentially, if the HA resource has failback enabled (which it has by default) and is part of a node affinity rule with node priority classes, the HA resource...
Sorry for the late reply, missed this thread in the new posts section.
This was already stated some of the other answers, but this is the expected behavior:
HA resources are by default configured with "failback" enabled. Failback in that sense...
Hi!
If I understand your description correctly, this is expected behavior.
As HA resources are "failback" by default and the HA resource is in a non-strict node affinity rule, the HA Manager does not allow the migration. This is because the HA...