Recent content by AhmedF

  1. A

    4.4 and memory usage

    I don't think having swappiness set to zero is a good idea as node kernel will start sending OOM to kill application to preserve any needed memory , I usually set it to 10 to minimize swap paging and yes I usually allocate 1 GB of memory for the node itself and allocate the rest the VMs/CTs
  2. A

    4.4 and memory usage

    The Linux kernel provides a tweakable setting that controls how often the swap file is used, called swappiness A swappiness setting of zero means that the disk will be avoided unless absolutely necessary (you run out of memory), while a swappiness setting of 100 means that programs will be...
  3. A

    rgmanager changed failover behaviour

    Did anyone notice this change in HA ? http://pve.proxmox.com/wiki/High_Availability_Cluster#HA_Cluster_maintenance_.28node_reboots.29
  4. A

    rgmanager changed failover behaviour

    Hi, I'm running proxmox clusters since 2.0 and now am running 3.4 root@cluster2b8:~# pveversion -v proxmox-ve-2.6.32: 3.4-166 (running kernel: 2.6.32-43-pve) pve-manager: 3.4-11 (running version: 3.4-11/6502936f) pve-kernel-2.6.32-32-pve: 2.6.32-136 pve-kernel-2.6.32-34-pve: 2.6.32-140...
  5. A

    Proxmox 4 HA VM Freeze State

    I tried to stop rgmanager manually , it stopped all CTs in the node successfully but they didn't start on other nodes like configured with failover domains , can you please tell me how to fix this ?
  6. A

    HA cluster problem with more than 100 CTs per node

    That helped and fixed the error with Dec 7 12:21:16 cluster3b1 rgmanager[41732]: [pvevm] Unable to create new inotify object: Too many open files at /usr/share/perl5/PVE/INotify.pm line 388. but after rebooting the same node , still getting these errors Dec 7 16:22:59 clusterxxx...
  7. A

    HA cluster problem with more than 100 CTs per node

    Thanks for your reply , will give this a try.
  8. A

    HA cluster problem with more than 100 CTs per node

    Hi, I'm running a HA cluster with 8 nodes and a shared NAS device totaling of 1000 CTs , everything is running very smoothly but when I need to reboot one of the nodes , I first stop rgmanager to relocate the HA CTs to other nodes then reboot the node but once it's started up I see these errors...
  9. A

    Proxmox 4 HA VM Freeze State

    I was afraid of such cases :( In my cluster 3.x , if one node goes down for any reason it's being fenced and all CTs are moved to other nodes during the downtime automatically and that's what I call HA. don't we all agree on that ?
  10. A

    Proxmox 4 HA VM Freeze State

    Agree but in proxmox 3.x when I shutdown a node manually and I did that a lot :) RGMANAGER will relocate all HA CTs to other nodes first then stop and then the node complete it's manual shutdown. is there a difference in proxmox 4.x ?
  11. A

    Proxmox 4 HA VM Freeze State

    So what's about this freeze state , shouldn't the HA CTs moved to another node(s) when the node fails ?
  12. A

    Proxmox 4 HA VM Freeze State

    Hmm that's a new behavior to me in HA , suppose we had a node down for any random power problems , HA used to fence this node and move all the VMs to another nodes depending on the failover domain setup in cluster.conf when the original node comes back online , it's all about the "nofailback"...
  13. A

    Manual command for applying HA new configuration

    Sorry is there any service need to be restarted after modifying cluster.conf , tried to restart rgmanager but no effect , didn't catch up the new modification I did with CTs.