ZFS Pool import strange (cosmetic) issue

apoc

Famous Member
Oct 13, 2017
1,045
162
108
Hello everybody,

I have a very strange situation here that has shown up after a reboot.
My one ZPOOL imports with WWN, SDx and VDEV at once.

It has worked different (always showing / using VDEVs) for a long time, but changed at some unknown point in time.
Since I have quite a few disks in my system I would like to get the old behavior back but seem unable to do so. Tried forcing usage of VDEVs by adjusting /etc/defaults/zfs but it did not work.

Please have a look to the Spare and Cache devices.
All others have transitioned to the WWN-representation.

Code:
  pool: HDD-POOL
 state: ONLINE
  scan: scrub repaired 0B in 7h51m with 0 errors on Sun Jun 16 07:51:34 2019
config:

    NAME                              STATE     READ WRITE CKSUM
    HDD-POOL                          ONLINE       0     0     0
      mirror-0                        ONLINE       0     0     0
        wwn-0x50014ee2064c0407        ONLINE       0     0     0
        wwn-0x50014ee25ba11386        ONLINE       0     0     0
      mirror-1                        ONLINE       0     0     0
        wwn-0x50014ee25ba14733        ONLINE       0     0     0
        wwn-0x50014ee25ba15612        ONLINE       0     0     0
      mirror-2                        ONLINE       0     0     0
        wwn-0x50014ee601d8038e        ONLINE       0     0     0
        wwn-0x50014ee2064c0078        ONLINE       0     0     0
      mirror-3                        ONLINE       0     0     0
        wwn-0x50014ee603bb9256        ONLINE       0     0     0
        wwn-0x50014ee20617bbac        ONLINE       0     0     0
      mirror-4                        ONLINE       0     0     0
        wwn-0x50014ee659150891        ONLINE       0     0     0
        wwn-0x50014ee65946b0ae        ONLINE       0     0     0
    logs
      mirror-5                        ONLINE       0     0     0
        wwn-0x50026b777504193f-part3  ONLINE       0     0     0
        wwn-0x5002538043584d30-part3  ONLINE       0     0     0
    cache
      sdd2                            ONLINE       0     0     0
      sdl2                            ONLINE       0     0     0
    spares
      C0-S5_HDD_WDWX81A6357403        AVAIL   

errors: No known data errors

  pool: SSD-POOL
 state: ONLINE
  scan: scrub repaired 0B in 0h8m with 0 errors on Sun Jun 16 00:08:11 2019
config:

    NAME                              STATE     READ WRITE CKSUM
    SSD-POOL                          ONLINE       0     0     0
      mirror-0                        ONLINE       0     0     0
        wwn-0x50026b777504193f-part1  ONLINE       0     0     0
        wwn-0x5002538043584d30-part1  ONLINE       0     0     0
    spares
      wwn-0x50014ee603bfb028          AVAIL   

errors: No known data errors

Has anyone experienced this before? And some helpful ideas?
The VDEVs are populated ok:

Code:
C0-S0_HDD_WDWXC1A81V2678          C1-S1_HDD_WDWXH1E61JDZE4-part1
C0-S0_HDD_WDWXC1A81V2678-part1    C1-S1_HDD_WDWXH1E61JDZE4-part9
C0-S0_HDD_WDWXC1A81V2678-part9    C1-S2_HDD_WDWXC1A81V1322
C0-S1_HDD_WDWXH1E61JDWK1          C1-S2_HDD_WDWXC1A81V1322-part1
C0-S1_HDD_WDWXH1E61JDWK1-part1    C1-S2_HDD_WDWXC1A81V1322-part9
C0-S1_HDD_WDWXH1E61JDWK1-part9    C1-S3_HDD_WDWXD1A61R5612
C0-S2_HDD_WDWXF1E61YHW25          C1-S3_HDD_WDWXD1A61R5612-part1
C0-S2_HDD_WDWXF1E61YHW25-part1    C1-S3_HDD_WDWXD1A61R5612-part9
C0-S2_HDD_WDWXF1E61YHW25-part9    C1-S4_HDD_WDWX11E83LT139
C0-S3_HDD_WDWXH1E61JDTX8          C1-S4_HDD_WDWX11E83LT139-part1
C0-S3_HDD_WDWXH1E61JDTX8-part1    C1-S4_HDD_WDWX11E83LT139-part9
C0-S3_HDD_WDWXH1E61JDTX8-part9    C1-S5_HDD_WDWX91A53F3930
C0-S4_HDD_WDWX71A63V2718          C1-S5_HDD_WDWX91A53F3930-part1
C0-S4_HDD_WDWX71A63V2718-part1    C1-S5_HDD_WDWX91A53F3930-part9
C0-S4_HDD_WDWX71A63V2718-part9    C1-S7_SSD_S0Z4NEAC916520
C0-S5_HDD_WDWX81A6357403          C1-S7_SSD_S0Z4NEAC916520-part1
C0-S5_HDD_WDWX81A6357403-part1    C1-S7_SSD_S0Z4NEAC916520-part2
C0-S5_HDD_WDWX81A6357403-part9    C1-S7_SSD_S0Z4NEAC916520-part3
C0-S7_SSD_50026B777504193F        O-P0_HDD_WDWX40AB9K7989
C0-S7_SSD_50026B777504193F-part1  O-P2_HDD_WDWXD1E33SXHH4
C0-S7_SSD_50026B777504193F-part2  O-P2_HDD_WDWXD1E33SXHH4-part1
C0-S7_SSD_50026B777504193F-part3  O-P2_HDD_WDWXD1E33SXHH4-part9
C1-S0_HDD_WDWXC1A81V2876          O-P3_HDD_WDWX91A6387047
C1-S0_HDD_WDWXC1A81V2876-part1    O-P3_HDD_WDWX91A6387047-part1
C1-S0_HDD_WDWXC1A81V2876-part9    O-P3_HDD_WDWX91A6387047-part9
C1-S1_HDD_WDWXH1E61JDZE4

I am running the most up to date Proxmox version with patchlevel as of today.
Issue appeared a few weeks back but I did ignore it for some time...
With best regards and many thanks in advance

Thomas
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!