zfs 2.1 roadmap

Whatever

Active Member
Nov 19, 2012
267
13
38
We uploaded a bunch of kernels with newer ZFS versions yesterday:
  • Proxmox VE 6.4 (oldstable):
    • pve-kernel-5.4.143-1-pve (5.4.143-1) with ZFS 2.0.6
    • pve-kernel-5.11.22-5-pve (5.11.22-10~bpo10+1) with ZFS 2.0.6
  • Proxmox VE 7.0 (stable):
    • pve-kernel-5.11.22-5-pve (5.11.22-10) with ZFS 2.0.6
    • pve-kernel-5.13.14-1-pve (5.13.14-1) with ZFS 2.1.1
The 5.13 based kernel is still opt-in only, it will be the one we default to in Proxmox VE 7.1 (planned for 2021/Q4).
That means that 5.11 is slowly on its way out, and that's why we did not bother with updating the ZFS module there to the 2.1 series.

To test ZFS 2.1 and the 5.13 based kernel add the pvetest repo and do:
Bash:
apt update
apt full-upgrade
apt install pve-kernel-5.13
# -> reboot

Are you sure that pve-kernel 5.11 test ships with ZFS 2.0.6?

On my test node I see:

1632905204765.png
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,826
1,311
164
South Tyrol/Italy
shop.proxmox.com
Are you sure that pve-kernel 5.11 test ships with ZFS 2.0.6?
Yes, pretty sure, I did the build ;)
https://git.proxmox.com/?p=pve-kernel.git;a=shortlog;h=refs/heads/pve-kernel-5.11

The thing is that we do not divide user-space tools per major version in separate packages as they're backward compatible anyway. So, if you just update but do not install the pve-kernel-5.13 package you'll get 2.1.1 user-space but 2.0.6 kernel module.

You can check both, user and kernel version with zfs -V, for example:
Bash:
zfs -V
zfs-2.1.1-pve1
zfs-kmod-2.0.6-pve1
uname -a
Linux prod2 5.11.22-5-pve #1 SMP PVE 5.11.22-10 (Tue, 28 Sep 2021 08:15:41 +0200) x86_64 GNU/Linux

And for 5.13 based kernel it looks like:
Bash:
zfs -V
zfs-2.1.1-pve1
zfs-kmod-2.1.1-pve1
uname -a
Linux prod1 5.13.14-1-pve #1 SMP PVE 5.13.14-1 (Tue, 28 Sep 2021 06:16:44 +0200) x86_64 GNU/Linux
 

Whatever

Active Member
Nov 19, 2012
267
13
38
Yes, pretty sure, I did the build ;)
https://git.proxmox.com/?p=pve-kernel.git;a=shortlog;h=refs/heads/pve-kernel-5.11

The thing is that we do not divide user-space tools per major version in separate packages as they're backward compatible anyway. So, if you just update but do not install the pve-kernel-5.13 package you'll get 2.1.1 user-space but 2.0.6 kernel module.

You can check both, user and kernel version with zfs -V, for example:
Bash:
zfs -V
zfs-2.1.1-pve1
zfs-kmod-2.0.6-pve1
uname -a
Linux prod2 5.11.22-5-pve #1 SMP PVE 5.11.22-10 (Tue, 28 Sep 2021 08:15:41 +0200) x86_64 GNU/Linux

And for 5.13 based kernel it looks like:
Bash:
zfs -V
zfs-2.1.1-pve1
zfs-kmod-2.1.1-pve1
uname -a
Linux prod1 5.13.14-1-pve #1 SMP PVE 5.13.14-1 (Tue, 28 Sep 2021 06:16:44 +0200) x86_64 GNU/Linux

Thomas, thanks for clarification.
Are they (user-space 2.1.1 and kernel 2.0.6 100% compatible?
 

chrcoluk

Member
Oct 7, 2018
115
16
23
42
I am actually glad you kept 6.4 test kernel on 2.0.6, 2.0.6 probably less risky than 2.1 at the moment.

--

I just updated and it pulled down 5.11.22-4 not 5.11.22-5 and zfs still on 2.0.5..
 
Last edited:

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,826
1,311
164
South Tyrol/Italy
shop.proxmox.com
I am actually glad you kept 6.4 test kernel on 2.0.6, 2.0.6 probably less risky than 2.1 at the moment.
Proxmox VE 6.4 is in bug & security fix only mode since the release of Proxmox VE 7.0, so we won't take in new feature releases of upstream project, iow. PVE 6.4 will stay on ZFS 2.0.x.

I just updated and it pulled down 5.11.22-4 not 5.11.22-5 and zfs still on 2.0.5..
As mentioned, it's only on the pvetest repository at time of writing, it will move to no-subscription in a bit and only later to the enterprise repository, at least if no issue pops up.
 
  • Like
Reactions: chrcoluk

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!