[SOLVED] xterm.js cutting off characters in Firefox


Active Member
Mar 24, 2018
After upgrading to pve v7, xterm is cutting off bottom of characters in Firefox (v90). I tried changing the settings for xterm but no luck. It works just fine in chrome and edge browser. I have included a snip of xterm.

Hmm, have you done a full reload of the GUI after the upgrade? CRTL+R for example?

Might be that some older parts of the GUI are still cached by the browser.
probably a font issue..
you can change the font (and font-size) in the 'Settings' window (top right username -> settings)
78.14.0esr, which I believe is the most recent Debian 11 version, of Firefox (ESR) also (still) has this problem. Is this not reproducable by the Proxmox developers?
Seeing the same chopped off characters with Firefox 92.0.1...


Last edited:
I was wondering about that on macOS and then I found this, so yeah, it's FireFox - MS-Edge (Chromium) displays correctly


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!