[SOLVED] Wireguard on unprivileged LXC seems to be broken after a recent update

Sandbo

Member
Jul 4, 2019
65
6
13
32
I updated Proxmox via the GUI today, after a reboot I realized my LXC wireguard client can no longer connect to a wireguard server as usual.
The journal shows the below:

Code:
Jul 11 16:35:00 CSWG2 wg-quick[334]: [#] ip link add wg0 type wireguard
Jul 11 16:35:00 CSWG2 wg-quick[341]: Error: Unknown device type.
Jul 11 16:35:00 CSWG2 wg-quick[343]: Unable to access interface: Protocol not supported
Jul 11 16:35:00 CSWG2 wg-quick[334]: [#] ip link delete dev wg0
Jul 11 16:35:00 CSWG2 wg-quick[344]: Cannot find device "wg0"

It looks like now the device wg0 cannot be created as before. Do you have any idea?

Update:
It looks like the kernel update did not install the headers automatically, you can follow the guide here to do so:
https://securityboulevard.com/2019/04/howto-install-wireguard-in-an-unprivileged-container-proxmox/

It nows works for me again.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!