[SOLVED] Wireguard in CT on Proxmox 6.1


New Member
Apr 15, 2020
Hello everyone,

I got some problems settung up wireguard in a container (Debian 10) using latest Proxmox.

I have seen tutorials, where one needs to install wireguard on the host and add the module via "dkms autoinstall".

However, each time I tried this using pve-manager/6.1-7/13e58d5e (running kernel: 5.3.18-2-pve), dkms was not able to find the linux headers.
Module build for kernel 5.3.18-2-pve was skipped since the kernel headers for this kernel does not seem to be installed.
I know, that one must install pve-headersto get the kernel headers, and I even tried to download and install the pve-headers-5.3.18-2-pve_5.3.18-2_amd64.deb package for my kernel (from http://download.proxmox.com/debian/pve/dists/buster/pve-no-subscription/binary-amd64/). Both tries resulted in no success.
Additionally, setting the kernelsourcedir when trying to execute dkms autoinstall resulted in no luck.

I would like to mention that I managed to set it up on a node that is currently running pve-manager/6.1-5/9bf06119 (running kernel: 5.3.13-2-pve) using the same way.

I read on https://forum.proxmox.com/threads/linux-kernel-5-3-for-proxmox-ve.59398/page-2 that I should install pve-headers-5.3 via apt, no luck (not found).
On https://forum.proxmox.com/threads/linux-kernel-5-4-for-proxmox-ve.66854/ that wireguard-dkms can be installed from buster-backports. This resulted in the same error

How do you do this?

I hope you can help me
Thanks in advance


Proxmox Staff Member
Staff member
Jul 28, 2015
South Tyrol/Italy

easiest to do it is to add the buster-backports repo:

echo 'deb http://ftp.debian.org/debian buster-backports main contrib' >> /etc/apt/sources.list.d/buster-backports.list

update and install the pve-headers (or pve-headers-5.x if one runs older kernel) package, then the wireguard-dkms one:

apt update
apt install pve-headers
apt install wireguard-dkms

That works well here.


New Member
Apr 15, 2020
Thanks for the fast reply.

Well, I tried this right now but I still get:
Error! Your kernel headers for kernel 5.3.18-2-pve cannot be found. Please install the linux-headers-5.3.18-2-pve package, or use the --kernelsourcedir option to tell DKMS where it's located
Additionally, I only see pve-headers-4*** when searching via apt. Do i need to enable pve-testing?

I got it, I had stretch in my pve repository
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!