Windows Server 2022 VM freezed - virtio: zero sized buffers are not allowed

Max2048

New Member
May 19, 2022
14
0
1
Guten Tag, bei meinem Host hängt sich eine Windows Server 2022 VM (mit englischer ISO ;) ) regelmäßig (alle 2-3 Tage) auf. Es ist ein 3-Knoten-Mesh-Cluster mit CEPH im Einsatz, PVE 7.2 (Kernel: Linux pve01 5.15.64-1-pve #1 SMP PVE 5.15.64-1 (Thu, 13 Oct 2022 10:30:34 +0200) x86_64 GNU/Linux). Der Windows-Ereignislog zeigt in der VM beim Auftreten des Ereignisses keine Fehler/Warnungen im Log an. Auf der VM läuft ein SQL Server 2019, auch dieser hat keine Probleme laut SQL-Server Log. RDP-Verbindung, sowie die VM-Console ist zu dem Zeitpunkt auch nicht mehr möglich und bleibt einfach mit schwarzem Bildschirm hängen. Alle Festplatten sowie der Arbeitsspeicher der Host Systeme wurden bereits geprüft, die Abstürze treten auf allen drei Hosts auf. Es betrifft allerdings nur eine Windows VM von vier.

Einzig auf dem Host finde ich einen Hinweis, dort erscheint die folgende Meldung im Journal. Danach reagiert die VM nicht mehr wie oben beschrieben, bis zum Reset.
Code:
QEMU[3519011]: kvm: virtio: zero sized buffers are not allowed

Hat jemand eine Idee was das sein könnte?

VM-Config
Code:
agent: 1
balloon: 0
boot: order=scsi0
cores: 6
cpu: host
machine: pc-q35-6.2
memory: 32768
meta: creation-qemu=6.2.0,ctime=1657105335
net0: virtio=76:90:CE:B7:21:69,bridge=vmbr4
numa: 0
onboot: 1
ostype: win11
scsi0: ceph_storage:vm-104-disk-0,discard=on,size=100G
scsi1: ceph_storage:vm-104-disk-1,backup=0,cache=writeback,discard=on,size=500G
scsi2: ceph_storage:vm-104-disk-2,discard=on,size=10G
scsihw: virtio-scsi-pci
smbios1: uuid=5829521f-0c23-431c-9806-c7ee8aab6694
sockets: 1
startup: order=3,up=30,down=30
vmgenid: 1c6d5ca2-862b-49c5-848d-453cbe000164
 
Last edited:

mira

Proxmox Staff Member
Staff member
Aug 1, 2018
2,105
251
103
Welche VirtIO Treiber Version ist denn installiert? Hier gerne mal versuchen die aktuellste zu installieren und schauen wie es sich dann verhält.
 

Max2048

New Member
May 19, 2022
14
0
1
Aktuell ist "Virtio-win-guest-tools" in Version 0.1.217 installiert. Es gibt wie ich sehe bereits eine neuere Version. Das werde ich mal probieren und mich zurückmelden.
 

Max2048

New Member
May 19, 2022
14
0
1
Welche VirtIO Treiber Version ist denn installiert? Hier gerne mal versuchen die aktuellste zu installieren und schauen wie es sich dann verhält.
Es sieht so aus, als lassen sich die derzeitigen Virtio Treiber nicht mit dem Installer aus der virtio-guest-tools.iso installieren. Die Installation schlägt fehl, sieht nach diesem Fehler aus: https://github.com/virtio-win/virtio-win-guest-tools-installer/issues/33 passt auch zu meiner Version... Die alten Virtio guest tools lassen sich also evtl. nicht deinstallieren... gibt es da einen Workaround für? In dem Git-Issue ist leider nichts zu finden.

Die Alternative wäre, dass ich für jedes Virtio-Gerät im Gerätemanager den Treiber manuell suche, indem ich zum entsprechenden Pfad auf der ISO navigiere, also z.B. den Ordner vioserial für den Virtio Serial Driver, netkvm für den Red Hat VirtIO Ethernet Adapter, etc.. Würde das funktionieren?
 
Last edited:

Max2048

New Member
May 19, 2022
14
0
1
Hilft Dir zwar nicht, aber ich habe das selbe Problem (Windows Server VM stürzt ab sobald zum Domain Controller angehoben)

Ich konnte es auf das Netzwerk einschränken, das scheint bei mir alle paar Stunden einfach wegzubrechen. Was ja unterm Strich auch wieder auf die VirtIO Treiber zurück zuführen ist.
Hey, deinen Thread hatte ich auch schon durchgelesen. Es gibt ein paar Gemeinsamkeiten, das stimmt. Allerdings sind bei mir der Host & andere VMs komplett unberührt von den VM-Abstürzen dieser einen VM. Hast du die neusten Virtio Treiber 0.1.225 im Einsatz? Bisher hänge ich noch auf 0.1.217 fest, bis ich eine Möglichkeit zur sauberen Installation der neuen Treiber finde...

edit: Bei mir läuft ein DC mit den Virtio Treibern 0.1.217 und englischer ISO ohne Probleme. Hat die folgende Config, falls dir das weiterhilft:
Code:
agent: 1
boot: order=scsi0
cores: 2
cpu: host
machine: pc-q35-6.2
memory: 4096
meta: creation-qemu=6.2.0,ctime=1657105335
net0: virtio=EE:74:64:57:C5:7A,bridge=vmbr4
numa: 0
onboot: 1
ostype: win11
scsi0: ceph_storage:vm-100-disk-0,discard=on,size=32G
scsihw: virtio-scsi-pci
smbios1: uuid=6038dfaf-22d7-492c-9b9d-2b41a27e2c36
sockets: 1
startup: order=2,up=30,down=30
vmgenid: 93bc6ea8-583b-47b0-9b4f-9871892788b4
 
Last edited:
Ich habe nach der Installation mit der 217 das Netzwerk, Stufe dann auf q35-6.2 hoch und aktualisiere auf 225. Hast Du ein DE Image von Windows Server 2022? ich versuche demnächst mit der EN Version, da soll es angeblich nicht diese Probleme geben (Windows Server 2022 virtio)
 

Max2048

New Member
May 19, 2022
14
0
1
Ich habe nach der Installation mit der 217 das Netzwerk, Stufe dann auf q35-6.2 hoch und aktualisiere auf 225. Hast Du ein DE Image von Windows Server 2022? ich versuche demnächst mit der EN Version, da soll es angeblich nicht diese Probleme geben (Windows Server 2022 virtio)
Ich habe alle meine Server mit der englischen ISO installiert und danach das deutsche Sprachpaket installiert... vielleicht sollte ich das wieder entfernen?
 
Die allgemeine Erfahrung aus dem Thread zeigt, sobald die DE Version oder das Language Pack drüber ist kein Schritt mehr zurück möglich ist.
 

Max2048

New Member
May 19, 2022
14
0
1
Die allgemeine Erfahrung aus dem Thread zeigt, sobald die DE Version oder das Language Pack drüber ist kein Schritt mehr zurück möglich ist.
Das lese ich etwas anders heraus aus den Posts von cwt [1] [2], da ich ja mit einer Original-Englisch ISO installiert habe. Naja, einen Versuch ist es wert. Ich melde ich zurück nach dem Entfernen des deutschen Sprachpakets, ob damit auch wieder das Virtio-Treiber Update funktioniert.

[1] https://forum.proxmox.com/threads/windows-server-2022-virtio.97887/post-507148
[2] https://forum.proxmox.com/threads/windows-server-2022-virtio.97887/post-509218
 
Lass es mich wissen, bin sehr an einer Lösung intressiert
 
Die 215 habe ich immer zur Installation des Netzwerktreiber und des SCSI-Treiber. Ich versuche es gerade mit der EN Version und der 225
 

Max2048

New Member
May 19, 2022
14
0
1
Lass es mich wissen, bin sehr an einer Lösung intressiert
Hallo, kurzes Feedback nach ca. einer Woche. Englisches Sprachpaket installieren, Englisch auf Default für alles setzen, Deutsches Sprachpaket deinstallieren. Nachdem ich dies durchgeführt habe bei einer ursprünglich mit englischer ISO installierter VM, verhält sich alles so wie es sein soll. Keine Abstürze mehr. auf Holz klopf

Virtio Treiber habe ich nicht aktualisiert.
 

Max2048

New Member
May 19, 2022
14
0
1
Laut diesem Bug-Report scheint eine weitere Lösung zu sein Hotplug für alle Devices zu deaktivieren in den VM-Options. Soll wohl auch mit deutscher ISO dann funktionieren.
 

fpausp

Well-Known Member
Aug 31, 2010
559
36
53
Austria near Vienna
Bei mir läuft die 2022 essential deutsch momentan mit folgender config:

1669230036137.png

auf einem HP Proliant DL380 Gen9:

1669230254236.png


Domain Controller ist installiert, PostgreSQL heute dazu installiert. Mal sehen wie stabil es läuft...
 

Max2048

New Member
May 19, 2022
14
0
1

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!