Windows Server 2008 Blue Screen when upgrading from Proxmox 4 to 6 - changing OS type to Vista did NOT work.

Jake Messinger

Active Member
Nov 16, 2017
We have a Dell R510 with Firmware 1.12. Yes I know it needs an update.
Dual Intel Xeon 5660 with 6 sticks of 16 gig DDR3 Reg Buff dual rank 133
2 of the 3 system drives in Raidz crashed at the same time so I had to rebuild the system drive.
Decided to Try proxmox 6 and do a zpool import to find the 5 drive raid z where the Windows Server 2008 lived.
I manually recreated the Config from reviewing the data in a backup. I have successfully done this several times before. I LOVE the automatic zpool import although I usually have to -f it since it thinks it is a foreign pool! Luckily I DID NOT upgrade the zfs pool or I would have NOT had a reverse path.

Wen we start the VM, we get a Blue screen about 1/3rd of the way into loading drivers. I have tweaked the settings for the CPU and OS type including setting it to Windows Vista, etc... I made sure that the Server was all apt-get updated and dist-upgraded. I never could get the VM running under Proxmox 6.
No amount of changing CPU flags seemed to make it boot.
Here is the config:

boot: dc
bootdisk: virtio0
cores: 6
memory: 24576
name: TS03.WinSrv2008r2Ent.DC.Exchange
net1: virtio=B2:82:56:A1:89:5E,bridge=vmbr0
numa: 0
onboot: 1
ostype: win7
smbios1: uuid=bec8f82f-b187-4fb1-9f39-7ce09304b686
sockets: 2
virtio0: local2:608/vm-608-disk-1.qcow2,cache=writeback,size=2000G

And YES I know qcow.. It should have been installed on the 2nd raidz zfs rpool i created with 5 drives, but instead I created a local folder on that zfs pool called local2. Not sure why we didnt go with a zfs block device, but this shouldn't be what is causing the problem. All that causes is slower performance.

I resorted to reinstalling an OLD ISO of Proxmox 4.4x and did EXACTLY the same thing and the VM does properly boot up so we are back up and running.

So has ANYONE been able to restore an image from backup OR a manual recovery such as what is above and gotten a machine that was created under Proxmox 3 or 4 to run under 5 or 6 with the Xeon 5600 series processor? Is that my issue? Could it be an old Dell Bios issue? How will I ever be able to migrate this machine ? Will I have to just abandon it and create a Windows 2012 or 2016 or later on a new Proxmox 6?

Jake Messinger
Adjunct Professor,
Bauer College of Business
University of Houston.
Do you have another machine available to test this on so you can keep the current working config running?

One guess of mine is that maybe the drivers for the current virtio disk backend could be too old. You could try to change the disk backend to ide or sata. If that is actually the case you can then use the method described in the last section in this wiki page [0] to add the current drivers before changing the boot disk backend again. I would recommend to switch to SCSI with the SCSI Virtio Controller for the best performance.

Booting Windows in safe mode with extended logging can also reveal which driver is causing the blue screen.

Thanks for the reply. It would not boot in IDE mode. That was the first thing I tried. I tried booting in every drive mode. I booted in safe mode and it blue screens after loading about 30 drivers. I cant look at the log if I can't get it booted. My next step was to try to try analyzing the memory dump.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!