Windows 2008R2 guest can't disable disk cache

r4pt0x

Member
Jan 5, 2012
53
0
6
I just installed a new W2K8 R2 guest to one of our Proxmox hosts, installed virtio-drivers for disk, ballooning and network and just wanted to disable the windows write-cache, but i get an error about disabling the cache is not possible for that device.

Another 2K8 R2 server is running with write cache disabled and i can switch it on and off without any problem or error messages
On both hosts the disk and controller type for the VM is virtio.

Used 1.59 and 1.65 virtio driver package version, no difference on both systems - the first one will let me change the settings, the new one doesn't.

Is there any way to force windows to disabe the cache (e.g. by registry?). The windows manual entry linked at the settings window is as useless as usual...

Thanks!
 

tarax

Member
Apr 2, 2010
43
5
8
Hi snowman66,

Thanks for your answer. Will try that but have to restart the VMs :(

[EDIT]

BTW, I don't see the point of linking the guest cache setting to the host one ?

Bests
 
Last edited:

snowman66

Active Member
Dec 1, 2010
254
1
38
BTW, I don't see the point of linking the guest cache setting to the host one ?
I guess the mix of newer version of windows and virtio driver can see disk cache settings. With windows xp is completely different where you can use default option cache=none and turn off write cache inside VM without any "tweak".
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!