Win10 VM Backup in a few seconds - using QEMU dirty bitmaps

martin

Proxmox Staff Member
Staff member
Apr 28, 2005
725
1,231
144
Here are two backup logs of my fresh installed Windows 10 VM (snapshot backup) to a Proxmox Backup Server.

First Backup run: 1 minute, 25 seconds
Code:
INFO: starting new backup job: vzdump 111 --mailto abc@proxmox.com --node xyz7 --storage pbs-store --remove 0 --mode snapshot
INFO: Starting Backup of VM 111 (qemu)
INFO: Backup started at 2020-07-10 16:21:37
INFO: status = running
INFO: VM Name: win10-demo
INFO: include disk 'scsi0' 'local-lvm:vm-111-disk-0' 32G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/111/2020-07-10T14:21:37Z'
INFO: issuing guest-agent 'fs-freeze' command
INFO: issuing guest-agent 'fs-thaw' command
INFO: started backup task '6dcfeac9-7811-4517-ae4b-b973f80cda42'
INFO: resuming VM again
INFO: status: 3% (1000.0 MiB of 32.0 GiB), duration 3, read: 333.3 MiB/s, write: 333.3 MiB/s
INFO: status: 4% (1.6 GiB of 32.0 GiB), duration 6, read: 204.0 MiB/s, write: 204.0 MiB/s
INFO: status: 6% (2.1 GiB of 32.0 GiB), duration 9, read: 193.3 MiB/s, write: 193.3 MiB/s
INFO: status: 8% (2.7 GiB of 32.0 GiB), duration 12, read: 180.0 MiB/s, write: 180.0 MiB/s
INFO: status: 10% (3.2 GiB of 32.0 GiB), duration 15, read: 184.0 MiB/s, write: 184.0 MiB/s
INFO: status: 11% (3.8 GiB of 32.0 GiB), duration 18, read: 202.7 MiB/s, write: 202.7 MiB/s
INFO: status: 13% (4.3 GiB of 32.0 GiB), duration 21, read: 170.7 MiB/s, write: 170.7 MiB/s
INFO: status: 15% (4.8 GiB of 32.0 GiB), duration 24, read: 174.7 MiB/s, write: 174.7 MiB/s
INFO: status: 16% (5.3 GiB of 32.0 GiB), duration 27, read: 182.7 MiB/s, write: 182.7 MiB/s
INFO: status: 18% (5.9 GiB of 32.0 GiB), duration 30, read: 185.3 MiB/s, write: 185.3 MiB/s
INFO: status: 20% (6.4 GiB of 32.0 GiB), duration 33, read: 185.3 MiB/s, write: 185.3 MiB/s
INFO: status: 22% (7.1 GiB of 32.0 GiB), duration 36, read: 222.7 MiB/s, write: 222.7 MiB/s
INFO: status: 23% (7.7 GiB of 32.0 GiB), duration 39, read: 193.3 MiB/s, write: 193.3 MiB/s
INFO: status: 25% (8.2 GiB of 32.0 GiB), duration 42, read: 176.0 MiB/s, write: 176.0 MiB/s
INFO: status: 27% (8.9 GiB of 32.0 GiB), duration 45, read: 253.3 MiB/s, write: 253.3 MiB/s
INFO: status: 35% (11.3 GiB of 32.0 GiB), duration 48, read: 812.0 MiB/s, write: 812.0 MiB/s
INFO: status: 37% (12.0 GiB of 32.0 GiB), duration 51, read: 258.7 MiB/s, write: 258.7 MiB/s
INFO: status: 39% (12.7 GiB of 32.0 GiB), duration 54, read: 206.7 MiB/s, write: 206.7 MiB/s
INFO: status: 41% (13.2 GiB of 32.0 GiB), duration 57, read: 172.0 MiB/s, write: 172.0 MiB/s
INFO: status: 46% (14.9 GiB of 32.0 GiB), duration 60, read: 596.0 MiB/s, write: 596.0 MiB/s
INFO: status: 54% (17.6 GiB of 32.0 GiB), duration 63, read: 910.7 MiB/s, write: 910.7 MiB/s
INFO: status: 63% (20.2 GiB of 32.0 GiB), duration 66, read: 912.0 MiB/s, write: 912.0 MiB/s
INFO: status: 71% (23.0 GiB of 32.0 GiB), duration 69, read: 949.3 MiB/s, write: 949.3 MiB/s
INFO: status: 80% (25.7 GiB of 32.0 GiB), duration 72, read: 917.3 MiB/s, write: 917.3 MiB/s
INFO: status: 88% (28.4 GiB of 32.0 GiB), duration 75, read: 913.3 MiB/s, write: 913.3 MiB/s
INFO: status: 97% (31.3 GiB of 32.0 GiB), duration 78, read: 1008.0 MiB/s, write: 1008.0 MiB/s
INFO: status: 100% (32.0 GiB of 32.0 GiB), duration 81, read: 225.3 MiB/s, write: 225.3 MiB/s
INFO: backup was done incrementally, reused 20.58 GiB (64%)
INFO: transferred 32.00 GiB in 81 seconds (404.5 MiB/s)
INFO: Finished Backup of VM 111 (00:01:25)
INFO: Backup finished at 2020-07-10 16:23:02
INFO: Backup job finished successfully
TASK OK

Second backup: 7 seconds
Code:
INFO: starting new backup job: vzdump 111 --mode snapshot --remove 0 --storage pbs-store --mailto abc@proxmox.com --node xyz7
INFO: Starting Backup of VM 111 (qemu)
INFO: Backup started at 2020-07-10 16:28:17
INFO: status = running
INFO: VM Name: win10-demo
INFO: include disk 'scsi0' 'local-lvm:vm-111-disk-0' 32G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/111/2020-07-10T14:28:17Z'
INFO: issuing guest-agent 'fs-freeze' command
INFO: issuing guest-agent 'fs-thaw' command
INFO: started backup task 'd3f3ca48-abe1-4544-a061-03055cb67e27'
INFO: resuming VM again
INFO: using fast incremental mode (dirty-bitmap), 1.2 GiB dirty of 32.0 GiB total
INFO: status: 89% (1.1 GiB of 1.2 GiB), duration 3, read: 362.7 MiB/s, write: 362.7 MiB/s
INFO: status: 100% (1.2 GiB of 1.2 GiB), duration 4, read: 124.0 MiB/s, write: 124.0 MiB/s
INFO: backup was done incrementally, reused 30.84 GiB (96%)
INFO: transferred 1.18 GiB in 4 seconds (303.0 MiB/s)
INFO: Finished Backup of VM 111 (00:00:07)
INFO: Backup finished at 2020-07-10 16:28:24
INFO: Backup job finished successfully
TASK OK
 

H4R0

Well-Known Member
Apr 5, 2020
616
138
48
Only works with non encrypted storage ? It should not matter ?!

As soon as i activate encryption, dirty bitmaps stops working.

I used pvesm to let pbs generate the encryption key "pvesm set backup --encryption-key autogen"

I also tried removing all backups and rebooting, still with encryption enabled qemu dirty bitmaps is not used. With encryption disabled it is.
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
8,150
1,593
164
Only works with non encrypted storage ? It should not matter ?!

As soon as i activate encryption, dirty bitmaps stops working.

I used pvesm to let pbs generate the encryption key "pvesm set backup --encryption-key autogen"

I also tried removing all backups and rebooting, still with encryption enabled qemu dirty bitmaps is not used. With encryption disabled it is.

please post the full logs and version information. bitmap and encryption support are not related at all.
 

H4R0

Well-Known Member
Apr 5, 2020
616
138
48
Fresh install of pve and pbs using no-subscription repo, upgraded to newest versions

<version.log>

First backup without storage encryption enabled:
<first backup not encrypted.log>

Second backup without storage encryption enabled:
Note: dirty bitmaps is used
<second backup not encrypted.log>

Now deleting all existing backups on backup storage, enabling encryption and rebooting (reboot should not matter but still)

Only thing changed:
pvesm set backup --encryption-key autogen
reboot

First backup with encryption enabled:
<first backup encrypted.log>

Second backup with encryption enabled:
Note: dirty bitmaps is not used !
<second backup encrypted.log>
 

Attachments

  • first backup encrypted.log
    5.1 KB · Views: 8
  • first backup not encrypted.log
    4.9 KB · Views: 3
  • second backup encrypted.log
    4.8 KB · Views: 6
  • second backup not encrypted.log
    1.1 KB · Views: 3
  • version.log
    1.1 KB · Views: 5

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
8,150
1,593
164
works here:
Code:
INFO: starting new backup job: vzdump 123456789 --mode snapshot --storage pbs-enya-crypt --remove 0 --node nora
INFO: Starting Backup of VM 123456789 (qemu)
INFO: Backup started at 2020-07-23 11:06:34
INFO: status = running
INFO: VM Name: tmpfsbackuptest
INFO: include disk 'scsi0' 'ramdisk:123456789/vm-123456789-disk-0.qcow2' 1G
INFO: include disk 'scsi1' 'bigpool:vm-123456789-disk-0' 1G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/123456789/2020-07-23T09:06:34Z'
INFO: enabling encryption
INFO: started backup task 'a215c80f-1440-40c0-8da0-ac30328d5e22'
INFO: resuming VM again
INFO: status: 14% (304.0 MiB of 2.0 GiB), duration 3, read: 101.3 MiB/s, write: 101.3 MiB/s
INFO: status: 28% (592.0 MiB of 2.0 GiB), duration 6, read: 96.0 MiB/s, write: 96.0 MiB/s
INFO: status: 42% (876.0 MiB of 2.0 GiB), duration 9, read: 94.7 MiB/s, write: 94.7 MiB/s
INFO: status: 74% (1.5 GiB of 2.0 GiB), duration 12, read: 217.3 MiB/s, write: 217.3 MiB/s
INFO: status: 100% (2.0 GiB of 2.0 GiB), duration 14, read: 260.0 MiB/s, write: 260.0 MiB/s
INFO: backup was done incrementally, reused 1020.00 MiB (49%)
INFO: transferred 2.00 GiB in 14 seconds (146.3 MiB/s)
INFO: Finished Backup of VM 123456789 (00:00:14)
INFO: Backup finished at 2020-07-23 11:06:48
INFO: Backup job finished successfully
TASK OK

INFO: starting new backup job: vzdump 123456789 --storage pbs-enya-crypt --mode snapshot --remove 0 --node nora
INFO: Starting Backup of VM 123456789 (qemu)
INFO: Backup started at 2020-07-23 11:06:51
INFO: status = running
INFO: VM Name: tmpfsbackuptest
INFO: include disk 'scsi0' 'ramdisk:123456789/vm-123456789-disk-0.qcow2' 1G
INFO: include disk 'scsi1' 'bigpool:vm-123456789-disk-0' 1G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/123456789/2020-07-23T09:06:51Z'
INFO: enabling encryption
INFO: started backup task '15460cf0-2a73-476d-83fa-dd30a7a97f98'
INFO: resuming VM again
INFO: using fast incremental mode (dirty-bitmap), 0.0 B dirty of 2.0 GiB total
INFO: status: 0% (0.0 B of 0.0 B), duration 0, read: 0 B/s, write: 0 B/s
INFO: Finished Backup of VM 123456789 (00:00:01)
INFO: Backup finished at 2020-07-23 11:06:52
INFO: Backup job finished successfully
TASK OK

seems like this is broken with the current set of packages in the repo, but fixed already in current master which will be tagged and uploaded soon!
 
  • Like
Reactions: H4R0

H4R0

Well-Known Member
Apr 5, 2020
616
138
48
works here:
Code:
INFO: starting new backup job: vzdump 123456789 --mode snapshot --storage pbs-enya-crypt --remove 0 --node nora
INFO: Starting Backup of VM 123456789 (qemu)
INFO: Backup started at 2020-07-23 11:06:34
INFO: status = running
INFO: VM Name: tmpfsbackuptest
INFO: include disk 'scsi0' 'ramdisk:123456789/vm-123456789-disk-0.qcow2' 1G
INFO: include disk 'scsi1' 'bigpool:vm-123456789-disk-0' 1G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/123456789/2020-07-23T09:06:34Z'
INFO: enabling encryption
INFO: started backup task 'a215c80f-1440-40c0-8da0-ac30328d5e22'
INFO: resuming VM again
INFO: status: 14% (304.0 MiB of 2.0 GiB), duration 3, read: 101.3 MiB/s, write: 101.3 MiB/s
INFO: status: 28% (592.0 MiB of 2.0 GiB), duration 6, read: 96.0 MiB/s, write: 96.0 MiB/s
INFO: status: 42% (876.0 MiB of 2.0 GiB), duration 9, read: 94.7 MiB/s, write: 94.7 MiB/s
INFO: status: 74% (1.5 GiB of 2.0 GiB), duration 12, read: 217.3 MiB/s, write: 217.3 MiB/s
INFO: status: 100% (2.0 GiB of 2.0 GiB), duration 14, read: 260.0 MiB/s, write: 260.0 MiB/s
INFO: backup was done incrementally, reused 1020.00 MiB (49%)
INFO: transferred 2.00 GiB in 14 seconds (146.3 MiB/s)
INFO: Finished Backup of VM 123456789 (00:00:14)
INFO: Backup finished at 2020-07-23 11:06:48
INFO: Backup job finished successfully
TASK OK

INFO: starting new backup job: vzdump 123456789 --storage pbs-enya-crypt --mode snapshot --remove 0 --node nora
INFO: Starting Backup of VM 123456789 (qemu)
INFO: Backup started at 2020-07-23 11:06:51
INFO: status = running
INFO: VM Name: tmpfsbackuptest
INFO: include disk 'scsi0' 'ramdisk:123456789/vm-123456789-disk-0.qcow2' 1G
INFO: include disk 'scsi1' 'bigpool:vm-123456789-disk-0' 1G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/123456789/2020-07-23T09:06:51Z'
INFO: enabling encryption
INFO: started backup task '15460cf0-2a73-476d-83fa-dd30a7a97f98'
INFO: resuming VM again
INFO: using fast incremental mode (dirty-bitmap), 0.0 B dirty of 2.0 GiB total
INFO: status: 0% (0.0 B of 0.0 B), duration 0, read: 0 B/s, write: 0 B/s
INFO: Finished Backup of VM 123456789 (00:00:01)
INFO: Backup finished at 2020-07-23 11:06:52
INFO: Backup job finished successfully
TASK OK

seems like this is broken with the current set of packages in the repo, but fixed already in current master which will be tagged and uploaded soon!

good to know, was kinda weird as encryption should not affect dirty bitmaps and it makes a huge difference on backup time so i definitely want to use dirty bitmaps.

im gonna setup another testlab with development branch to test most up to date packages in the future
 

elmacus

Active Member
Mar 20, 2011
71
3
28
Testing Windows Server 2012, every time big incremental size:
using fast incremental mode (dirty-bitmap), 266.1 GiB dirty of 328.0 GiB total
------
backup was done incrementally, reused 301.62 GiB (91%)
transferred 266.07 GiB in 1679 seconds (162.3 MiB/s)

Daily optimize on C-disc is on. But i will try weekly now and see if that fixes dirty-bitmap.
Ceph on SSD, Debian get like 3 GB dirty of 1 TB on all VM's.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,619
959
163
Please do not post the same in two threads!
 
  • Like
Reactions: blackout

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!