Webgui funktioniert nicht

Discussion in 'Proxmox VE (Deutsch)' started by josch12, May 13, 2018.

  1. josch12

    josch12 New Member

    Joined:
    Oct 20, 2017
    Messages:
    17
    Likes Received:
    0
    Hallo,
    ich habe versucht einen neuen Node in mein Cluster einzufügen, was ziemlich schief ging ...

    jetzt seh ich nur noch einen Teil meiner Nodes ( gehen ich aber z.b auf Prox3, sehe kann ich diesen ganz normal verwalten, sehe dafür die anderen ausgegraut )

    [​IMG]
    [​IMG]

    mit meinen Recherchen komme ich nicht weiter..

    mein erste Schritt wäre es das Interface aufzuräumen, da Ds1501 und proxown nicht mehr aktiv sind.

    ich habe unter /etc/pve/nodes mittels
    rm -R proxown & rm -R ds1501 die Ordner gelöscht.

    da die beiden noch immer nicht verschwunden sind, habe ich:

    service pvestatd restart

    und das pve cluster neugestartet, leider ohne Erfolg
     
  2. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Hi,

    dein Cluster ist in 2 hälften zerfallen.
    Ich würde sagen du hast ein Netzwerkproblem.

    Kannst du von jedem cluster node die übrigen Cluster mitglieder pingen?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. josch12

    josch12 New Member

    Joined:
    Oct 20, 2017
    Messages:
    17
    Likes Received:
    0
    Hallo,
    danke für deine Antwort.

    Ja ping geht. ich komm auch per ssh von dem einen auf den anderen Node.

    die Nodes liegen auch alle im gleichen Netzwerk.
     
  4. josch12

    josch12 New Member

    Joined:
    Oct 20, 2017
    Messages:
    17
    Likes Received:
    0
    Kann es was mit einer corosync Config Datei zu tun haben ?

    ich hatte gestern beim testen den Fehler,
    den Fehler das die Datei /etc/pve/corosync.conf nicht existieren würde.

    ich habe leider nicht mehr den genauen Befehl...
     
    #4 josch12, May 14, 2018
    Last edited: May 14, 2018
  5. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Ja das kann sein.

    kontrollier ob die Datei auf allen Nodes gleich ist und zwar unter folgenden Pfaden.
    /etc/pve/corosysnc/conf
    /etc/corosysnc/corosync.conf
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. josch12

    josch12 New Member

    Joined:
    Oct 20, 2017
    Messages:
    17
    Likes Received:
    0
    Guten Morgen,
    habe gestern Abend noch geschaut,
    die Corosync dataien waren leer. Ich habe im Wiki ein Example gefunden, und auf dem Prox4 gestestet, dieses war auch erst erfolgreich, und Prox 4 war wieder imm Cluster ersichtlich.

    beim Versuch Prox3 in das Cluster einzubinden , war dies nicht mehr erfolgriech. am schluss konnte ich auf Prox3 und 4 Corosny und das Cluster selbst nicht mehr ausführen.

    Damit zumindest die VPS online sind habe ich gestern die Nodes vom Cluster getrennt. diese laufen nun als Single Mode.

    Das ist natürlich keine Dauerlösung.

    Bekomm ich diese wieder in einen Cluster-Verbund obwohl vms laufen, oder muss ich von den Vms nun erst Dumps erstellen, cluster neu einrichten, und die Dumps wieder einlesen ?

    Die Daten selbst liegen auf einem Shared Storage, ist also nichts lokal auf der Platte.
     
  7. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Mit VM/CT kannst du keinen node in einen Cluster hinzu fuegen.
    Wenn die VM/CT am shared storage liegen ist die schnelste und beste variante volgende.

    1.) stop VM/CT
    2.) copiere mit scp die VMID.conf (/etc/pve/(qemu-server|lxc)/VMID.conf) in den Cluster.
    3.) starte VM/CT im Cluster.

    Wenn alle VM im Cluster sind kannst du den leeren Node zum Cluster joinen.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. josch12

    josch12 New Member

    Joined:
    Oct 20, 2017
    Messages:
    17
    Likes Received:
    0
    Dankeschön !
    werde ich heute Abend versuchen.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice