WebAuthn registration failed

showiproute

Member
Mar 11, 2020
365
13
18
33
Austria
Okay so it seems that the package fixed the issues.
BUT I am still unable to have a Webauthn registration which works for the whole PVE cluster.

Can you please update your manual to that?
I think many other customers which run > 1 PVE as a cluster would benefit from that.
 

showiproute

Member
Mar 11, 2020
365
13
18
33
Austria
I tinkered a bit around with RP & ID.

On my 2nd server I see following "error": authentication failure; rhost=::ffff:192.168.10.2 user=mmuehlbacher@hks msg=The clients relying party origin does not match our servers information
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,975
820
163
33
Vienna
AFAIK, you must remove the origin from the datacenter.cfg ( since each host hast its own origin) and the rp must be a suffix domain e.g. for 'pve1.x.y' and 'pve2.x.y' the rp should be 'x.y'
 
  • Like
Reactions: showiproute

showiproute

Member
Mar 11, 2020
365
13
18
33
Austria
AFAIK, you must remove the origin from the datacenter.cfg ( since each host hast its own origin) and the rp must be a suffix domain e.g. for 'pve1.x.y' and 'pve2.x.y' the rp should be 'x.y'
It worked - thanks!

But you used rp twice in your previous message.
The right way is to delete the origin, id = domain, rp = pve.domain

So in my case the config looks like webauthn: id=hks.lan,rp=proxmox1.hks.lan
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!