VM's dont start after Upgrade

Oer2001

Member
Jul 12, 2011
43
0
6
Hi,

I upgraded to the latest version:

Code:
root@proxmox1:~# pveversion -v
pve-manager: 2.0-42 (pve-manager/2.0/3d6d8258)
running kernel: 2.6.32-10-pve
proxmox-ve-2.6.32: 2.0-63
pve-kernel-2.6.32-10-pve: 2.6.32-63
pve-kernel-2.6.32-7-pve: 2.6.32-60
lvm2: 2.02.88-2pve2
clvm: 2.02.88-2pve2
corosync-pve: 1.4.1-1
openais-pve: 1.1.4-2
libqb: 0.10.1-2
redhat-cluster-pve: 3.1.8-3
resource-agents-pve: 3.9.2-3
fence-agents-pve: 3.1.7-1
pve-cluster: 1.0-25
qemu-server: 2.0-28
pve-firmware: 1.0-15
libpve-common-perl: 1.0-21
libpve-access-control: 1.0-17
libpve-storage-perl: 2.0-14
vncterm: 1.0-2
vzctl: 3.0.30-2pve2
vzprocps: 2.0.11-2
vzquota: 3.0.12-3
pve-qemu-kvm: 1.0-7
ksm-control-daemon: 1.1-1

After upgrade some of our VM's do not start. Only Windows XP vm's are affected (we have 3).
The behaviour is, that the vm starts up to Windows XP boot picture.
It takes only 170MB of Ram but 50% of CPU and than nothing changed (we wait 2 hours).

Other VM's with Linux or Windows 2008 are not affected.

Thank you for help.

Regards
 
Last edited:

Oer2001

Member
Jul 12, 2011
43
0
6
Downgrading to:

pve-qemu-kvm_1.0-5_amd64.deb

solve the problem.

But perheps we can find another solution.

Regards
 

spirit

Famous Member
Apr 2, 2010
5,687
626
133
www.odiso.com
Hi, could you try this package ?
http://odisoweb1.odiso.net/pve-qemu-kvm_1.0-7_amd64.deb

(this is a updated pve-qemu-kvm package with last kvm, not yet release in proxmox repositories).
They are big change for the moment on a feature which can impact 32bits windows system.

also, could you try to add in your vm configuration file:

args: -machine pc,kernel_irqchip=on

or
args: -machine pc,kernel_irqchip=off

to see the difference.

I'll try to do more tests with XP this week.
 

Oer2001

Member
Jul 12, 2011
43
0
6
Hi,

yes the new pve-qemu-kvm version solve the problem.
The Windows XP VM's starts like the other VM's.

Setting the args without the new pve-qemu-kvm version did not work.
With the new pve-qemu-kvm version there is no need of the special args.

Thank you.

Regards
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!