[SOLVED] VM MASQUERADE and Firewall issue

Discussion in 'Proxmox VE: Networking and Firewall' started by Karpiu, Dec 25, 2016.

  1. Karpiu

    Karpiu New Member

    Joined:
    Sep 26, 2016
    Messages:
    4
    Likes Received:
    0
    Hello,
    I set MASQUERADE for all my VM on vmbr0 and all works fine until I set Firewall on interface for VM after that I can't go out to Internet. All my politics on input/out set for ACCEPT but still going out doesn't work at all. Did I miss something ? When Firewall is disabled all works well.
     
  2. LnxBil

    LnxBil Well-Known Member

    Joined:
    Feb 21, 2015
    Messages:
    2,768
    Likes Received:
    215
    Karpiu likes this.
  3. Karpiu

    Karpiu New Member

    Joined:
    Sep 26, 2016
    Messages:
    4
    Likes Received:
    0
    Thx for a hint, It works great but sad in this solution is manual adding to every VM/CT :(
    In your iptables lane I had to add fwbr<VMID>i0 instead of <VMID>i0 in input interface:

    Code:
    iptables -t raw -A PREROUTING -i fwbr103i0 -j CT --zone 1
    Is there any solution to turn this trick automatically ?
     
  4. LnxBil

    LnxBil Well-Known Member

    Joined:
    Feb 21, 2015
    Messages:
    2,768
    Likes Received:
    215
    I already mailed with @dietmar and this is not expected behaviour, yet I do not know if this will be fixed in upcoming releases or not. I have not filed a bug report about this.
     
  5. Kai Lilleby

    Kai Lilleby New Member
    Proxmox VE Subscriber

    Joined:
    Mar 31, 2016
    Messages:
    1
    Likes Received:
    0
    ref the previous post (dated feb 21. 2015) - whats the official proxmox way of handling this? whats you reply @dietmar ?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice