Vlan, Bond and OVS

Discussion in 'Proxmox VE: Networking and Firewall' started by vakhtang, Oct 26, 2018.

  1. vakhtang

    vakhtang New Member

    Joined:
    Oct 26, 2018
    Messages:
    3
    Likes Received:
    0
    Greeting
    Got some interesting problem while configuring OVS. but, first, let me describe network
    1) Two lan interfaces bonded property on switch
    2) Single VLAN # 519
    3) Proxmox 5.2, free edition :)
    Ok first i configure with linux bridges, config is follow
    Code:
    auto lo
    iface lo inet loopback
    
    iface eno1 inet manual
    
    iface eno2 inet manual
    
    auto bond0
    iface bond0 inet manual
            bond-slaves eno1 eno2
            bond-miimon 100
            bond-mode 802.3ad
            bond-xmit-hash-policy layer2+3
    
    auto bond0.519
    iface bond0.519 inet manual
    
    auto vmbr0
    iface vmbr0 inet static
            address  172.16.130.9
            netmask  255.255.255.0
            gateway  172.16.130.1
            bridge-ports bond0.519
            bridge-stp off
            bridge-fd 0
            dns-nameserver 8.8.8.8
    
    
    And as у result i can log in to GUI, mansge VM/CT and so on
    However, we have 300 different Vlan's and am to lazy to bring so many vmbs's that's why i decide to run on OVS
    But
    It's does not work!
    Config:
    Code:
    auto lo
    iface lo inet loopback
    iface eno1 inet manual
    iface eno2 inet manual
    
    auto bond0
    iface bond0 inet manual
      ovs_bridge vmbr0
      ovs_type OVSBond
      ovs_bonds eno1 eno2
    . ovs_options bond_mode=balance-tcp lacp=active other_config:lacp-time=fast
      mtu 9000
    
    
    auto vmbr0
    allow-ovs vmbr0
    iface vmbr0 inet manual
      ovs_type OVSBridge
      ovs_ports bond0 vlan519
      mtu 9000
    
    allow-vmbr0 vlan519
    iface vlan519 inet static
      ovs_type OVSIntPort
      ovs_bridge vmbr0
      ovs_options tag=519
      ovs_extra set interface ${IFACE} external-ids:iface-id=$(hostname -s)-${IFACE}-vif
      address 172.16.130.9
      netmask 255.255.255.0
      gateway 172.16.130.1
      dns-nameserver 8.8.8.8
      mtu 1500

    So, im doubt for now, what's wrong, and how to fix it?
     
    #1 vakhtang, Oct 26, 2018
    Last edited: Oct 26, 2018
  2. Klaus Steinberger

    Klaus Steinberger Active Member
    Proxmox Subscriber

    Joined:
    Jan 16, 2018
    Messages:
    165
    Likes Received:
    27
    is tag=50 really correct for vlan519 ? that sounds strange

    Also are the switch ports correctly configured with all those 300 VLAN's tagged on them?
     
  3. vakhtang

    vakhtang New Member

    Joined:
    Oct 26, 2018
    Messages:
    3
    Likes Received:
    0
    sorry, corrected to 519. Yes switch is ok, however, in OVS mode it's can't even reach 519 vlan, witch works in Linux Bridge
     
  4. Klaus Steinberger

    Klaus Steinberger Active Member
    Proxmox Subscriber

    Joined:
    Jan 16, 2018
    Messages:
    165
    Likes Received:
    27
    did you use the OVS Packages from proxmox repo or those from debian stretch? The packages from stretch are not working!
     
    vakhtang likes this.
  5. vakhtang

    vakhtang New Member

    Joined:
    Oct 26, 2018
    Messages:
    3
    Likes Received:
    0
    fff.... problem solved, problem was in openvswitch
    [QUOTE| Klaus Steinberger,[/QUOTE] Thank you!
     
  6. spirit

    spirit Well-Known Member

    Joined:
    Apr 2, 2010
    Messages:
    3,323
    Likes Received:
    135
    Note than you don't need to define 300vmbr.
    simply create a vmbr0 with bond0, then use vlan tag option in the vm.

    proxmox will create the others vmbr for you.
    (you can also use the vlan-aware option in the bridge, like this it'll be the same than ovs, 1bridge with vlan tagging on ports)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice