[SOLVED] Valid subscription is now invalid

Apr 26, 2018
I hope I am missing the big picture somewhere.

We have a valid Community subscription. I verified the subscription by logging in to https://shop.maurer-it.com. Our online account shows the subscription is valid to June 21, 2020.

I suspect updates from yesterday, which included libpve-access-control=5.1-10, might be the cause of the failure.

Trying to restore libpve-access-control=5.1-9 results in dependency warnings.

We have a cron job to check the subscription date and set an email alert within 15 days of the subscription expiring. That email alert arrived at 4:58 AM this morning with no expiration date. That means the pvesubscription command failed.

To continue, from the online account I copied the key, which is unchanged from previously, and ran pvesubscription set $KEY. No change in subscription status.

No change after running pvesubscription update --force.

Attempting to upload the key from the web interface results in the dialog being ghosted/disabled when pasting the copied key, probably because the key is unchanged.

I noticed the server ID is now different from previously.

I backed up /etc/apt/auth.conf and edited the server ID manually. Still no success.

With the manual edit I could access the enterprise repository from a web browser. Running apt update results in a 401 error.

As a last resort I rebooted the server.

The subscription remains invalid.

How do we remedy this problem?
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!