use the mail proxy service,HA cluster?

NICK_k

New Member
Sep 7, 2020
10
0
1
39
Hello ,
I only use the mail proxy service, and I have configured the HA cluster, MASTER: 192.168.1.30, NODE: 192.168.1.31, and DNS ABC.COM points to 192.168.1.30 and 192.168.1.31 ,Client sets Relay server to ABC.COM, but if one of them stops serving, the other will not take over the mailing service?
 
Last edited:

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
4,326
539
118
Depending on the clients, which try to relay via ABC.com - they usually should detect that they can't reach 192.168.1.30 and then try the next A record for ABC.com (192.168.1.31).

I Assume that you've setup the DNS records so that the fqdn you enter as relay for your clients resolves to both IP addresses
 

NICK_k

New Member
Sep 7, 2020
10
0
1
39
Yes, I have set DNS A record. If an exception occurs on 172.23.1.31, the client will fail to send mail. So i don't know how to solve this problem
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
4,326
539
118
Switching to another IP listed in the A record of a fqdn is something that most smtp-servers handle quite well - maybe the client-software has some settings which need to be tuned?

one other option could be to setup a tcp loadbalancer in front of your 2 PMGs (ha-proxy for instance)
 

NICK_k

New Member
Sep 7, 2020
10
0
1
39
I have reset Cluster,but fail.
How can I solve this problem?
MASTER: ProxmoxMG
Node:ProxmoxMG1

Error Code:
Oct 19 17:18:14 ProxmoxMG pmgmirror[27945]: starting cluster syncronization
Oct 19 17:18:15 ProxmoxMG pmgmirror[27945]: database sync 'ProxmoxMG1' failed - DBD::pg::st execute failed: ERROR: duplicate key value violates unique constraint "cstatistic_pkey"
DETAIL: Key (cid, rid)=(2, 59104) already exists. at /usr/share/perl5/PMG/DBTools.pm line 1086.
Oct 19 17:18:15 ProxmoxMG pmgmirror[27945]: cluster syncronization finished (1 errors, 0.38 seconds (files 0.26, database 0.11, config 0.00))
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
4,326
539
118
* easiest fix would be to remove the node and add it again
 

NICK_k

New Member
Sep 7, 2020
10
0
1
39
I delete /etc/pmg/cluster.conf from Master and Node, and reset Cluster,right?
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!