[Urgent] LXC backup (zfsvols) are corrupt !!!

Discussion in 'Proxmox VE: Installation and configuration' started by hregis, Apr 2, 2016.

  1. hregis

    hregis Member

    Joined:
    Feb 11, 2011
    Messages:
    37
    Likes Received:
    0
    Hello

    all LXC backup (in ZFS) are corrupt !! i try all methods (snapshots, suspend, stop - no compress, LZO, GZIP)

    after restore my LXC backup, all logs in "/var/log" of VM have disappeared and some services do not start (mysql, apache, etc ...)

    i check the content of tar.lzo backup and the /var/log is empty !!

    it's getting worse Proxmox 4 !!!
    we can not trust the backups ??????

    system reports is in attach-files

    Thank you
     

    Attached Files:

    #1 hregis, Apr 2, 2016
    Last edited: Apr 2, 2016
  2. pero

    pero New Member

    Joined:
    Apr 2, 2012
    Messages:
    11
    Likes Received:
    1
    I can confirm this bug.
    All my lxc backups exculdes /var/log.
    It happens on a node with zfsvols storage and a node with the default local lvm storage too
    I tried to put "stdexcludes: 0" in vzdump.conf, but not helped.
     
  3. pero

    pero New Member

    Joined:
    Apr 2, 2012
    Messages:
    11
    Likes Received:
    1
    If I run vzdump manually in the console with "-stdexcludes 0" parameter, then the log directories are saved succesfully.
    I found in the vzdump manual that the default value of the stdexcludes parameter is 1. I think it is wrong, it should be 0.
    For some reason the "stdexcludes: 0" in vzdump.conf is ignored.
    So I think Proxmox should append "-stdexcludes 0" to the parameters of vzdump to save lxc containers with the /var/log directories.
     
  4. fabian

    fabian Proxmox Staff Member
    Staff Member

    Joined:
    Jan 7, 2016
    Messages:
    3,193
    Likes Received:
    494
    This was already reported as bug #926 and is fixed in pve-manager >= 4.1-24. As a workaround until that version is available in pve-nosubscription/pve-enterprise you can edit cron jobs / command line parameters to include "-stdexcludes 0".
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. hregis

    hregis Member

    Joined:
    Feb 11, 2011
    Messages:
    37
    Likes Received:
    0
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice