Upgraded, storage not showing for backup

j.edward

New Member
Apr 2, 2012
20
0
1
Hi,

I had an issue with users not being able to change passwords, I installed the update and now they can. Only problem is, we cant see the storage for backups. I added a test storage, backups only, group permission, made sure user permissions are correct (PVEVMUser), set it shared. Still nothing, only visible as root.


ii libpve-access-control 1.0-18 Proxmox VE access control library
ii libpve-common-perl 1.0-26 Proxmox VE base library
ii libpve-storage-perl 2.0-17 Proxmox VE storage management library

Any ideas?

James
 

j.edward

New Member
Apr 2, 2012
20
0
1
here is my user.cfg

user:7.9.22.57@pve:1:0:::::
user:7.9.22.59@pve:1:0:::::
user:meow@pve:1:0:::::
user:7.9.22.15@pve:1:0::::
user:7.9.22.52@pve:1:0::::
user:testuser@pam:1:0:test:user:::
user:7.9.22.54@pve:1:0:::::
user:7.9.22.48@pve:1:0:::::
user:root@pam:1:0:::::

group:customers:::



acl:1:/vms/101:7.9.22.15@pve:pVEVMUser:
acl:1:/vms/103:7.9.22.48@pve,meow@pve:pVEVMUser:
acl:1:/vms/105:7.9.22.52@pve:pVEVMUser:
acl:1:/vms/109:7.9.22.57@pve:pVEVMUser:
acl:1:/vms/111:7.9.22.59@pve:pVEVMUser:
 

j.edward

New Member
Apr 2, 2012
20
0
1
You also need to set permissions on the storage.


Right, but like ive said, i've done all that. I just set it again, same problem.

acl:1:/storage/backups:meow@pve:pVEVMUser:


Logged out and in, still blank.
 

j.edward

New Member
Apr 2, 2012
20
0
1
Ah i see, PVEVMUser doesnt cover it. It must be DataStoreUser. Thats kind of a pain in the butt.
 

j.edward

New Member
Apr 2, 2012
20
0
1
What exactly is your suggestion?

Proxmox documentation that mentions PVEDatastoreUser? :)


Pay no attention to me. I'm just happy it works now. Since this is completed, I can continue to add customers to the control panel which reps Proxmox and makes us look good .. cause proxmox rules.

Thanks!
 

vlast

Guest
Update: SOLVED!
Storage content was mistakenly set to Containers, not Backup.

.....
I have the same problem. None of configured storages are displayed for selection in the backup module.
I followed recommendations in this thread and set permissions as follows (actually it was set by GUI):

user:sysadmin@pve:1:0:System:Administrator:::
acl:1:/vms/100:sysadmin@pve:Administrator:
acl:1:/storage/Backup:sysadmin@pve:Administrator:

Still no storage are displayed in drop-downs for backup.

What could possibly be the problem?
 
Last edited by a moderator:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!