Upgrade to 5 Failed

sourceminer

Active Member
Jan 7, 2015
48
0
26
Using:
deb http://download.proxmox.com/debian/pve stretch pve-no-subscription

Ran the updater command, and then it tells me:
562 upgraded, 173 newly installed, 11 to remove and 0 not upgraded.
Need to get 361 MB of archives.
After this operation, 315 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
librados2-perl libcorosync-common4 libcmap4 libcpg4 libquorum5 libcfg6 libtotem-pg5 libvotequorum8 corosync-pve corosync pve-cluster libdevmapper1.02.1 dmsetup liblvm2app2.2 lvm2 iproute2 libdevmapper-event1.02.1 liblvm2cmd2.02 dmeventd libpve-http-server-perl pve-docs libjs-extjs vncterm pve-libspice-server1 pve-qemu-kvm libpve-storage-perl pve-firewall pve-ha-manager qemu-server spiceterm novnc-pve pve-manager pve-container libpve-common-perl libpve-guest-common-perl criu lxcfs lxc-pve libpve-access-control grub-pc grub2-common grub-efi-ia32-bin grub-pc-bin grub-efi-amd64-bin grub-common ksm-control-daemon libcorosync4-pve libuutil1linux libnvpair1linux libzpool2linux libzfs2linux pve-kernel-4.10.17-3-pve pve-firmware proxmox-ve spl zfsutils-linux zfs-initramfs zfs-zed omping

Install these packages without verification? [y/N] y

The usual stuff.


Then it gives me this error:
Preparing to unpack .../1-libnvpair1linux_0.6.5.11-pve17~bpo90_amd64.deb ...

Unpacking libnvpair1linux (0.6.5.11-pve17~bpo90) ...

dpkg: error processing archive /tmp/apt-dpkg-install-KMjKgl/1-libnvpair1linux_0.6.5.11-pve17~bpo90_amd64.deb (--unpack):

trying to overwrite '/lib/libnvpair.so.1.0.1', which is also in package libnvpair1 0.6.5-pve9~jessie

Preparing to unpack .../2-libzpool2linux_0.6.5.11-pve17~bpo90_amd64.deb ...

Unpacking libzpool2linux (0.6.5.11-pve17~bpo90) ...

dpkg: error processing archive /tmp/apt-dpkg-install-KMjKgl/2-libzpool2linux_0.6.5.11-pve17~bpo90_amd64.deb (--unpack):

trying to overwrite '/lib/libzpool.so.2.0.0', which is also in package libzpool2 0.6.5-pve9~jessie

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Preparing to unpack .../3-libzfs2linux_0.6.5.11-pve17~bpo90_amd64.deb ...

Unpacking libzfs2linux (0.6.5.11-pve17~bpo90) ...

dpkg: error processing archive /tmp/apt-dpkg-install-KMjKgl/3-libzfs2linux_0.6.5.11-pve17~bpo90_amd64.deb (--unpack):

trying to overwrite '/lib/libzfs.so.2.0.0', which is also in package libzfs2 0.6.5-pve9~jessie

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Preparing to unpack .../4-zfsutils-linux_0.6.5.11-pve17~bpo90_amd64.deb ...

Unpacking zfsutils-linux (0.6.5.11-pve17~bpo90) ...

dpkg: error processing archive /tmp/apt-dpkg-install-KMjKgl/4-zfsutils-linux_0.6.5.11-pve17~bpo90_amd64.deb (--unpack):

trying to overwrite '/etc/default/zfs', which is also in package zfsutils 0.6.5-pve9~jessie

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Preparing to unpack .../5-zfs-zed_0.6.5.11-pve17~bpo90_amd64.deb ...

Unpacking zfs-zed (0.6.5.11-pve17~bpo90) ...

dpkg: error processing archive /tmp/apt-dpkg-install-KMjKgl/5-zfs-zed_0.6.5.11-pve17~bpo90_amd64.deb (--unpack):

trying to overwrite '/etc/zfs/zed.d/zed-functions.sh', which is also in package zfsutils 0.6.5-pve9~jessie

Errors were encountered while processing:

/tmp/apt-dpkg-install-KMjKgl/0-libuutil1linux_0.6.5.11-pve17~bpo90_amd64.deb

/tmp/apt-dpkg-install-KMjKgl/1-libnvpair1linux_0.6.5.11-pve17~bpo90_amd64.deb

/tmp/apt-dpkg-install-KMjKgl/2-libzpool2linux_0.6.5.11-pve17~bpo90_amd64.deb

/tmp/apt-dpkg-install-KMjKgl/3-libzfs2linux_0.6.5.11-pve17~bpo90_amd64.deb

/tmp/apt-dpkg-install-KMjKgl/4-zfsutils-linux_0.6.5.11-pve17~bpo90_amd64.deb

/tmp/apt-dpkg-install-KMjKgl/5-zfs-zed_0.6.5.11-pve17~bpo90_amd64.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

root@TNP-PMH01:~# apt-get update && apt-get dist-upgrade

Ign:1 http://linux.dell.com/repo/community/ubuntu jessie InRelease

Hit:2 http://security.debian.org stretch/updates InRelease

Get:3 http://linux.dell.com/repo/community/ubuntu jessie Release [24.9 kB]

Hit:4 http://download.proxmox.com/debian/pve stretch InRelease

Ign:5 http://ftp.debian.org/debian stretch InRelease

Get:6 http://linux.dell.com/repo/community/ubuntu jessie Release.gpg [836 B]

Hit:7 http://ftp.debian.org/debian stretch Release

Ign:6 http://linux.dell.com/repo/community/ubuntu jessie Release.gpg

Hit:8 http://linux.dell.com/repo/community/ubuntu jessie/openmanage amd64 Packages

Ign:8 http://linux.dell.com/repo/community/ubuntu jessie/openmanage amd64 Packages

Hit:8 http://linux.dell.com/repo/community/ubuntu jessie/openmanage amd64 Packages


Tried running a Repair :
apt --fix-broken install

Still would not be fixed.
Searched the forums found someone complaining of the same thing where by someone from Staff suggested they installed ZFS from another source (which is not the case here as we dont even use this).

Rebooted and of course this machine is not coming back up.



First Version 4.2-48
root@TNP-PMH02:~# pveversion -v
proxmox-ve: 4.2-48 (running kernel: 4.4.6-1-pve)
pve-manager: 4.2-2 (running version: 4.2-2/725d76f0)
pve-kernel-4.4.6-1-pve: 4.4.6-48
lvm2: 2.02.116-pve2
corosync-pve: 2.3.5-2
libqb0: 1.0-1
pve-cluster: 4.0-39
qemu-server: 4.0-72
pve-firmware: 1.1-8
libpve-common-perl: 4.0-59
libpve-access-control: 4.0-16
libpve-storage-perl: 4.0-50
pve-libspice-server1: 0.12.5-2
vncterm: 1.2-1
pve-qemu-kvm: 2.5-14
pve-container: 1.0-62
pve-firewall: 2.0-25
pve-ha-manager: 1.0-28
ksm-control-daemon: 1.2-1
glusterfs-client: 3.5.2-2+deb8u1
lxc-pve: 1.1.5-7
lxcfs: 2.0.0-pve2
cgmanager: 0.39-pve1
criu: 1.6.0-1
zfsutils: 0.6.5-pve9~jessie
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
3,409
654
133
South Tyrol/Italy
shop.maurer-it.com
WARNING: The following packages cannot be authenticated!

Sounds not usual, to be honest...

First Version 4.2-48
root@TNP-PMH02:~# pveversion -v
proxmox-ve: 4.2-48 (running kernel: 4.4.6-1-pve)

We only support upgrades to new major versions from the newest minor version of the previous major version, to say it complicated. :)

More simple: please upgrade to PVE 4.4 before you start an Upgrade to PVE 5. Else you do not have the release key of PVE 5 deployed and things will go wrong.
 

Tozz

Active Member
Mar 11, 2012
30
0
26
To be of assistance instead of telling people what they did wrong, here is the solution to this problem:

Run:
Code:
apt-get remove zfs-initramfs zfsutils-linux zfsutils

Afterwards, run:

Code:
apt-get -f install
apt-get upgrade

To finish the installation.
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
3,409
654
133
South Tyrol/Italy
shop.maurer-it.com
To be of assistance instead of telling people what they did wrong, here is the solution to this problem:

With 4.2 You simply do not have the GPG release Key of PVE 5.X available, which was only added with PVE 4.4 as I stated (sound like a good solution, IMO).
So please always update to PVE 4.4 before adding the PVE 5 repos and starting an upgrade, removing zfsutils is normally not needed and even if, it won't help on a missing GPG package repository release key...
 

Tozz

Active Member
Mar 11, 2012
30
0
26
The issue he was facing is not related to the GPG key. It is because 2 zfs packages contain the same file:

Code:
trying to overwrite '/etc/default/zfs', which is also in package zfsutils 0.6.5-pve9~jessie

The solution is zo uninstall the 3 packages I mentioned (and optionally reinstall them afterwards)

While you are correct that he _should_ have upgraded to the latest 4.x release prior to upgrading to 5.x, simply stating that does not really solve the issue now that we can conclude that he did not upgrade to the latest 4.x.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!