1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Uncompressed Backup Problem

Discussion in 'Proxmox VE: Installation and configuration' started by yarii, Nov 28, 2016.

  1. yarii

    yarii New Member

    Joined:
    Mar 24, 2014
    Messages:
    20
    Likes Received:
    1
    I've got a problem with backuping a VM to remote NAS whitch is mounted with samba to /mnt/z1

    This is the log:
    INFO: starting new backup job: vzdump 101 --compress 0 --node far --mode snapshot --remove 0 --storage z1
    INFO: Starting Backup of VM 101 (qemu)
    INFO: status = running
    INFO: update VM 101: -lock backup
    INFO: VM Name: iqBL
    INFO: include disk 'sata0' 'local:101/vm-101-disk-1.qcow2'
    INFO: backup mode: snapshot
    INFO: ionice priority: 7
    INFO: creating archive '/mnt/z1/dump/vzdump-qemu-101-2016_11_28-10_43_25.vma'
    INFO: started backup task '570f28c8-8aca-497d-964c-1d7b6bb0adcf'
    INFO: status: 0% (3801088/85899345920), sparse 0% (1286144), duration 1, 3/2 MB/s
    ERROR: vma_queue_write: write error - Invalid argument
    INFO: aborting backup job
    ERROR: Backup of VM 101 failed - vma_queue_write: write error - Invalid argument
    INFO: Backup job finished with errors
    TASK ERROR: job errors

    The problem only exists if I choose compresion=none.
    The backup process is done succesfully when I choose LZA compression.

    I use the newest proxmox and do autoupdates every day on that host.

    On local there is a mirror with ext4+lvm on it (standard instalation).
    On remote there is a ext4, remote share is mounted by samba on /mnt/z1.
    VM disks have qcow2 format.

    How to diagnose that?
    Does somebody challange with that or similar problem?

    Regards
    JK
     
  2. Trigve

    Trigve New Member

    Joined:
    Oct 15, 2016
    Messages:
    29
    Likes Received:
    0
  3. yarii

    yarii New Member

    Joined:
    Mar 24, 2014
    Messages:
    20
    Likes Received:
    1
    If local storage is checked as a backup storage the problem not exists.
    If samba storage is checked as a backup storage the problem exists.

    [9631705.054960] CIFS VFS: Error connecting to socket. Aborting operation.
    [9631705.055143] CIFS VFS: cifs_mount failed w/return code = -113

    All the time samba share is avaible and I can use mounted on /mnt/z1 remote cifs share.
     
  4. yarii

    yarii New Member

    Joined:
    Mar 24, 2014
    Messages:
    20
    Likes Received:
    1
  5. VDNKH

    VDNKH New Member

    Joined:
    Aug 8, 2016
    Messages:
    26
    Likes Received:
    0
    I have the same PROBLEM, i can do backup with compression lzo and gzip, but i cant with none compression, the vma format...
    The Storage is a CIFS mounted in a local directory on the proxmox server, i add this backup storage as a directory on the web gui.
    I do something wrong???
     

Share This Page