Ubuntu guest KVM stuck on Gbit.

Kephin

New Member
Apr 21, 2015
8
1
1
I have running an Ubuntu KVM. It is going to be used as an Asterisk server and therefore has two interfaces so as to route SIP traffic over a seperate interface to a seperate network.
They both work, but on the second interface i'm troubleshooting a packetloss issue. When looking at the interface with ethtool it reports it has an 1000mbit uplink to the switch.
The switch it is connected to is in fact 100mbit (dumb/non-managed), so i'm trying to change the duplex setting of said interface on the server end to 100mbit full without autonegotion. (ethtool -s eth1 speed 100 duplex full autoneg off)
This command indeed turns off the auto negotiation but seemingly does nothing with the Link speed. On the host I use the e1000 option as a network device.
What could I be missing?

Edit:

The host server this KVM runs on did in fact negotiate 100mbit.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!