1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trying to modify the headers - regex error?

Discussion in 'Mail Gateway: Installation and configuration' started by Nhoague, Jan 11, 2018.

  1. Nhoague

    Nhoague Member

    Joined:
    Sep 29, 2012
    Messages:
    53
    Likes Received:
    0
    Im just trying to add the SPAM level to the header and I am getting these errors. What does this mean? What patten is expected?

    This is on PMG 5 beta. Also note that I can't even go back to the original setting "SPAM: __SUBJECT__" without it giving me these errors also.

    Thanks
     

    Attached Files:

  2. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    12,232
    Likes Received:
    232
  3. Nhoague

    Nhoague Member

    Joined:
    Sep 29, 2012
    Messages:
    53
    Likes Received:
    0
    Bug posted. Thanks!
     
  4. Nhoague

    Nhoague Member

    Joined:
    Sep 29, 2012
    Messages:
    53
    Likes Received:
    0
    Could this be a bug also? The negative report of spam >= 10?
     

    Attached Files:

  5. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    12,232
    Likes Received:
    232
    do you run latest version? please check and post the output of:

    > pmgversion -v
     
  6. Nhoague

    Nhoague Member

    Joined:
    Sep 29, 2012
    Messages:
    53
    Likes Received:
    0
    root@pmg01:~# pmgversion -v
    proxmox-mailgateway: 5.0-4 (API: 5.0-43/51c9b72f, running kernel: 4.13.13-1-pve)
    pmg-api: 5.0-43
    pmg-gui: 1.0-20
    proxmox-spamassassin: 3.4.1-53
    proxmox-widget-toolkit: 1.0-9
    pve-kernel-4.13.13-1-pve: 4.13.13-31
    libpve-http-server-perl: 2.0-8
    lvm2: 2.02.168-2
    pve-firmware: 2.0-3
    libpve-common-perl: 5.0-23
    pmg-docs: 5.0-6
    pve-xtermjs: 1.0-2
    libarchive-perl: 3.2.1-1
    libxdgmime-perl: 0.01-3
    zfsutils-linux: 0.7.3-pve1~bpo9
    libpve-apiclient-perl: 2.0-2
    root@pmg01:~#
     
  7. Nhoague

    Nhoague Member

    Joined:
    Sep 29, 2012
    Messages:
    53
    Likes Received:
    0
    I found another situation where the regex is causing input errors. Under the "what" action group, create a new group called "Keyword" and then choose Match Field. I want to put a two word keyword in the Match Field Value box. It won't let me. Thanks!
     
  8. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    12,232
    Likes Received:
    232
    In order to get latest updates, you need to add the pmgtest repository to your sources.list.

    # deb http://download.proxmox.com/debian/pmg stretch pmgtest

    after this, you just have to run:

    > apt-get update
    > apt-get dist-upgrade
     
  9. Nhoague

    Nhoague Member

    Joined:
    Sep 29, 2012
    Messages:
    53
    Likes Received:
    0
    I am getting these results ...

    Reading package lists... Done
    W: The repository 'https://enterprise.proxmox.com/debian/pmg stretch Release' does not have a Release file.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    E: Failed to fetch https://enterprise.proxmox.com/debian/pmg/dists/stretch/pmg-enterprise/binary-amd64/Packages 401 Unauthorized
    E: Some index files failed to download. They have been ignored, or old ones used instead.
    root@pmg01:~#

    EDIT: Oh but not the GUI has a different list of updates available. Perhaps that's what it needed.
    EDIT: Nevermind ... same versions. So it still isn't pulling the pmgtest repo
     
  10. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    12,232
    Likes Received:
    232
  11. Nhoague

    Nhoague Member

    Joined:
    Sep 29, 2012
    Messages:
    53
    Likes Received:
    0
    I must be doing something wrong; I copy and paste this, but I still get the same results. Also, the link you sent is for proxmox-ve? Or do they share the same packages?
     
  12. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    12,232
    Likes Received:
    232
    You had two issues.

    1. you try to update from the pmg enterprise repo - as you have no key this will not work. (just uncomment the enterprise repo as long as you run the beta/testing).
    2. it looks you have a gpg key issue, so I sent you the link to install this - and yes, its the same keys for Proxmox VE and for the Proxmox Mail Gateway
     
  13. Nhoague

    Nhoague Member

    Joined:
    Sep 29, 2012
    Messages:
    53
    Likes Received:
    0
    Ok so I did all that, and heres a screenshot of my CLI. All look good? Now when I reboot the server it doesn't show 5.0-6?

    Thank you very much for your attention as well!
     

    Attached Files:

Share This Page