[TUTORIAL] The lxc gentoo template seems not to be working right

fireon

Famous Member
Oct 25, 2010
3,870
316
103
40
Austria/Graz
iteas.at
Hello all,

i installed the actual gentoo lxc template from proxmox. It is starting, but emerge did'nt work. Every ebuild give's this error message:
Code:
 * The ebuild phase 'die_hooks' has been aborted since PORTAGE_BUILDDIR
 * does not exist: '/var/tmp/portage/app-shells/zsh-5.6.2'
And "/var/tmp/portage/" exists, but not more. Rights are ok. Same as privileged CT.
While emerging some package, than be sure this is a bug in portage. Just append
Code:
FEATURES="-pid-sandbox"
This fix the problem. After this update Portage, and then the rest.
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,213
1,516
164
South Tyrol/Italy
shop.proxmox.com
Hmm, I did not update that one for a while - last time in July (where basic stuff worked, if my mind is remembering correctly, not sure if I tried an ebuild though...).

I can update it and take a look if it works now. Much thanks for telling with even a proposed fix!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!