Test failover CEPH not work

Discussion in 'Proxmox VE: Installation and configuration' started by teerawich, May 16, 2019.

  1. teerawich

    teerawich New Member

    Joined:
    Jan 17, 2018
    Messages:
    5
    Likes Received:
    0
    Hello,

    I have 3 nodes clusters with CEPH test Proxmox VE 5.4
    - 3 Mon
    - 6 OSD (2 x per node)
    - Configured 2 Replica
    - Running VM on CEPH storage

    Then I have shutdown 1 node for testing VM on CEPH, VM running but can't write to disk.

    How can I fix it ? Please recommended.

    Thank you.
     

    Attached Files:

  2. Alwin

    Alwin Proxmox Staff Member
    Staff Member

    Joined:
    Aug 1, 2017
    Messages:
    2,170
    Likes Received:
    191
    First off, don't run with replica 2, especially in small clusters. It can happen that no copy of an object is written on disk during failure/recovery. Besides that, if your min_size is also 2, then Ceph doesn't allow writes till 2 copies are established of all the objects in a pool. Best run with size 3 / min_size 2.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. teerawich

    teerawich New Member

    Joined:
    Jan 17, 2018
    Messages:
    5
    Likes Received:
    0
    Hello,

    It's work.

    Thank you.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice