systemd-timesyncd dead after upgrade from 4.4 to 5.1

pieteras.meyer

Active Member
Aug 13, 2014
110
6
38
Johannesburg, South Africa
Hi Guys

I have recently upgraded my cluster of 3 servers from 4.4 to latest 5.1

I have now noticed that the systemd-timesyncd service is not starting. shows as dead in the gui

service systemd-timesyncd status shows the below

Active: inactive (dead)
Condition: start condition failed at Tue 2018-03-20 23:13:39 SAST; 59min ago
└─ ConditionFileIsExecutable=!/usr/sbin/ntpd was not met
Docs: man:systemd-timesyncd.service(8)

Any Ideas on how to fix this?
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,554
925
163
maybe you have another ntp service running?
 

eXtremeSHOk

Active Member
Mar 15, 2016
33
14
28
39
The unit file detects the presence of "/usr/sbin/ntpd" if this is found, the service will never enable/start

Use the following commands
apt purge ntp
systemctl daemon-reload

---
I have updated the post-install.sh script located here https://github.com/extremeshok/xshok-proxmox
 
Last edited:

fireon

Famous Member
Oct 25, 2010
3,906
324
103
40
Austria/Graz
iteas.at
The unit file detects the presence of "/usr/sbin/ntpd" if this is found, the service will never enable/start

Use the following commands
apt purge ntp
systemctl daemon-reload

---
I have updated the post-install.sh script located here https://github.com/extremeshok/xshok-proxmox
On one server here i had the same problem. Normally it does not matter with ntp.
 
  • Like
Reactions: flames

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!