[SOLVED] systemd-boot "rootdelay" or ZFS_INITRD_POST_MODPROBE_SLEEP


Oct 7, 2016
Just reinstalled 2 hosts in a cluster with PVE 6, mirrored zfs EFI boot. All working fine except the zpool isn't imported right away on boot. About ~5 seconds after it fails to boot (cannot import rpool, no such pool available) all the disks are detected and I can simply do "zpool import rpool; exit" and it boots fine.
This happened with the same host while running PVE 5, but I fixed it with:


I applied the same fixes to the PVE 6 host, but they don't seem to do anything. I suspected the rootdelay=10 to not do anything since it isn't using GRUB.

* What's the equivalent of rootdelay=10 for systemd-boot? And how do I make that persistent across kernel updates?
* Why isn't ZFS_INITRD_PRE_MOUNTROOT_SLEEP=10 working?
pve6_1.jpg pve6_2.jpg

Thank you!


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!