Stuck on syncing

koby

Active Member
Jun 21, 2012
111
4
38
Natanya , Israel
Hello Guys,
I created a cluster according to the doc , but I forgot to open port 8006 open to both of the cluster node.
(I thought that I need only port 22...).
After that , I did open the needed port and try to sync ,
I do see the two node , but they are always on "syncing" position and not on active as it should be.
I also did some sync test and I manage to see the rule header name does sync.
In farther testing it seems that the attachment quarantine is not the same on both nodes as well as the virus quarantine is not the same .
Please advice.

I am working on PMG ver 6.3-5 on both nodes.

Best Regards ,
Koby Peleg Hen
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,387
709
133
33
Vienna
what do the logs say (syslog/journal)?
 

koby

Active Member
Jun 21, 2012
111
4
38
Natanya , Israel
Sorry can't find that.
Can you please be more precise.

Best Regards ,
Koby Peleg Hen
I manage to find this ..

Code:
failed: FATAL:  remaining connection slots are reserved for non-replication superuser connections at /usr/share/perl5/PMG/DBTools.pm line 68.cluster syncronization finished  (1 errors, 0.08 seconds (files 0.00, database 0.07, config 0.00))
Feb 02 19:17:19 smg01 pmgmirror[1637]: starting cluster syncronization
Feb 02 19:17:19 smg01 pmgmirror[1637]: database sync 'smg02' failed - DBI connect('dbname=Proxmox_ruledb;host=/run/pmgtunnel;port=2;','root',...) failed: FATAL:  remaining connection slots are reserved for non-replication superuser connections at /usr/share/perl5/PMG/DBTools.pm line 68.
Feb 02 19:17:19 smg01 pmgmirror[1637]: cluster syncronization finished  (1 errors, 0.09 seconds (files 0.00, database 0.09, config 0.00))
Feb 02 19:19:19 smg01 pmgmirror[1637]: starting cluster syncronization
Feb 02 19:19:19 smg01 pmgmirror[1637]: database sync 'smg02' failed - DBI connect('dbname=Proxmox_ruledb;host=/run/pmgtunnel;port=2;','root',...) failed: FATAL:  remaining connection slots are reserved for non-replication superuser connections at /usr/share/perl5/PMG/DBTools.pm line 68.
Feb 02 19:19:19 smg01 pmgmirror[1637]: cluster syncronization finished  (1 errors, 0.07 seconds (files 0.00, database 0.07, config 0.00))
Feb 02 19:21:19 smg01 pmgmirror[1637]: starting cluster syncronization
Feb 02 19:21:19 smg01 pmgmirror[1637]: database sync 'smg02' failed - DBI connect('dbname=Proxmox_ruledb;host=/run/pmgtunnel;port=2;','root',...) failed: FATAL:  remaining connection slots are reserved for non-replication superuser connections at /usr/share/perl5/PMG/DBTools.pm line 68.
Feb 02 19:21:19 smg01 pmgmirror[1637]: cluster syncronization finished  (1 errors, 0.08 seconds (files 0.00, database 0.08, config 0.00))
~

Please advice
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,387
709
133
33
Vienna
mhmm.. did you some customization of the postgres?
can you post a bit more of your syslog?
 

koby

Active Member
Jun 21, 2012
111
4
38
Natanya , Israel
Hello guys ,
I would like to info you that my issue was resolved by updating the systems.
I could see that was some update to postgesql , and immediate after it , the cluster become sync.
I am not really understand what truly happened.
But what important that it is fine now.
I hope it would help someone.

Best Regards
Koby Peleg Hen.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!