[SOLVED] Spam Quarantine E-Mail Adressen mit Anführungszeichen

Discussion in 'Proxmox Mail Gateway (Deutsch)' started by sb-jw, May 18, 2019.

  1. sb-jw

    sb-jw Active Member

    Joined:
    Jan 23, 2018
    Messages:
    551
    Likes Received:
    49
    Hallo zusammen,

    durch einen kleinen Scriptfehler habe ich leider nun in der Spam Quarantine E-Mail Adressen mit Anführungszeichen drin, wenn ich versuch die E-Mails in der Spam Quarantine für diese E-Mail zu löschen, erhalte ich immer eine Fehlermeldung. Auch per API kann ich diese nicht entfernen, in der Datenbank finde ich auch keine Einträge dazu. Die mir vorliegenden IDs aus dem Trackingcenter werden auch nicht von PMG akzeptiert.

    Code:
    root@spam01:~# pmgsh get /quarantine/spamusers
    200 OK
    [
       {
          "mail" : "\"body:dear\"@spam01.domain.tld"
       },
       {
          "mail" : "\"from:no-reply\"@domain.tld"
       },
       {
          "mail" : "\"spam01.domain.tld:26\"@spam01.domain.tld"
       },
       {
          "mail" : "\"subject:potential\"@spam01.domain.tld"
       }
    ]
    Code:
    root@spam01:~# pmgsh get /quarantine/spam --pmail \"body:dear\"@spam01.domain.tld
    400 Parameter verification failed.
    pmail: invalid format - value does not look like a valid email address
    
    get quarantine/spam  [OPTIONS]
    
    Hier habe ich auch bereits verschiedenste Variationen ausprobiert, die Zeichen mal konvertiert, mal escaped mal nicht usw.

    Code:
    root@spam01:~# pmgsh create /quarantine/content --action delete --id 1423875CDF09D507F15
    400 Parameter verification failed.
    id: value does not match the regex pattern
    create quarantine/content --action <string> --id <string> [OPTIONS]
    Jemand eine Idee, wie man das gelöst bekommt?

    Danke!
     
  2. sb-jw

    sb-jw Active Member

    Joined:
    Jan 23, 2018
    Messages:
    551
    Likes Received:
    49
    Ich habe gestern mal die beiden Gateways aktualisiert und heute morgen auf dem Smartphone noch mal versucht, nun ging es ohne Probleme.

    Ich vermute weniger, dass es am Smartphone lag wohl mehr an dem Update :)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice