Shutdown VM never timeout


Active Member
Jun 14, 2019
Hi, I just created a win7 x32 VM, and I am trying to use qm shutdown VMID --timeout 30 to shut it down, but I found that --timeout option is not working, the task won't stop unless I press Ctrl+C.

Here is the history:

root@node-us:~# date
Fri Jun 21 15:21:01 CST 2019
root@node-us:~# qm shutdown 10031 --timeout 10
^CVM quit/powerdown failed
root@node-us:~# date
Fri Jun 21 15:21:40 CST 2019
Hmm works just fine here on latest Proxmox VE 5.4:
# qm create 101 --name unshutdownable
# date; qm shutdown 101 --timeout 10; date
Fri 21 Jun 2019 10:07:40 AM CEST
VM quit/powerdown failed - got timeout
Fri 21 Jun 2019 10:07:50 AM CEST

This was on a dummy VM, i.e., one without OS running, which means it does not listens to ACPI events (which is normally triggered by us if no guest agent is marked as installed in the VM) and thus the shutdown will never work (only stop)..

Can you post your
pveversion -v
and maybe the VM config?

Edit: added my qm create comman which with I tested this..
Thanks for your help, I know it won't shut down because ACPI problem, but I think the timeout should work and let me stop it by force.

pveversion -v :

proxmox-ve: 5.4-1 (running kernel: 4.15.18-15-pve)
pve-manager: 5.4-6 (running version: 5.4-6/aa7856c5)
pve-kernel-4.15: 5.4-3
pve-kernel-4.15.18-15-pve: 4.15.18-40
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: not correctly installed
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-10
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-52
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-13
libpve-storage-perl: 5.0-43
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-37
pve-container: 2.0-39
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-6
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-2
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-52
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3

Config File:

agent: 1
balloon: 2048
boot: c
bootdisk: scsi0
cores: 2
ide2: local:10031/vm-10031-cloudinit.qcow2,media=cdrom,size=4M
ipconfig0: ip=185.***.***.***/27,gw=185.***.***.***
memory: 2048
name: BlalalaKMabaxft
net0: virtio=4E:74:58:43:63:C4,bridge=vmbr0,firewall=1
onboot: 0
scsi0: local:10031/vm-10031-disk-0.raw,size=50G
scsihw: virtio-scsi-pci
serial0: socket
smbios1: uuid=a5252520-902c-4b3f-aecf-7a9e9fd3a5b6
vmgenid: abd345d6-bced-47dd-a918-6205f4bd0491
I know it won't shut down because ACPI problem, but I think the timeout should work and let me stop it by force.

My sentence was just a FYI for my dummy VM. Also if you want a force stop after the timeout you need to add the forceStop parameter anyway, else it just aborts after the timeout, not force stop or anything.

Ah, OK, you use a agent. So there the default timeout is 10 minutes. IMO there we really should pass along the timeout if a specific one was requested.
Could you please open a enhancement request at mentioning that with guest agent used the timeout is not passed along to the respective QMP command "guest-shutdown" and thus the default of 10 minutes is always used.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!