Set MTU on Guest

spirit

Famous Member
Apr 2, 2010
5,782
676
133
www.odiso.com
I don't understand why this was not integrated yet. There are clearly multiple use cases for this. It can be a hidden option (advanced checkbox) just like with the NICs for the host.

Thanks
it's not available in gui, but you can already add ",mtu=xxxx" with command line or in vm config file.
 

c3r

New Member
May 12, 2022
1
2
3
Hi All, I needed this feature (mtu), so i had to correct patches from Tacid (good work, thank U).

Code:
patch -d /usr/share/pve-manager/js/  < pvemanagerlib_mtu.patch
patch -d /usr/share/perl5/PVE/ < qemu_server_mtu.patch

systemctl restart pvedaemon
systemctl restart pveproxy

Tested on:
pve-manager/7.2-3/c743d6c1 (running kernel: 5.13.19-6-pve)
 

Attachments

  • pve_7.2-3_mtu_patch.zip
    1.5 KB · Views: 4
Last edited:

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,558
927
163
Was looking for this. Hope this get's merged into PVE soon.

@tom @t.lamprecht
Why wasn't this merged yet? A patch was send back in 2018, followed by other patches.

Thanks
Maybe you did not enable the "Advanced" view? Please check again.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,558
927
163
thanks for the pointer and yes, you are right, I mixed this up with the host network settings. we try to apply this soon.
 
  • Like
Reactions: DerDanilo

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!