Set IPv6AcceptRA in CT Network Config

Discussion in 'Proxmox VE: Networking and Firewall' started by MrJester888, Sep 13, 2018.

  1. MrJester888

    MrJester888 New Member
    Proxmox VE Subscriber

    Joined:
    Sep 2, 2018
    Messages:
    11
    Likes Received:
    1
    I have a container sitting on a network with DHCPv4 and v6. Setting a static v4 address disables DHCPv4. Setting a static v6 address, does not. Per the systemd documentation, I need to set "IPv6AcceptRA=false" in the [network] section of the interface config do disable DHCPv6 addressing.

    Setting this manually works fine. However, it does not survive a reboot. Ideally, there would be a simple checkbox in the CT network config to enable/disable IPv6AcceptRA. Short of that, is there a way to inject that statement into the interface configuration at boot?

    https://www.freedesktop.org/software/systemd/man/systemd.network.html#IPv6AcceptRA=
     
  2. MrJester888

    MrJester888 New Member
    Proxmox VE Subscriber

    Joined:
    Sep 2, 2018
    Messages:
    11
    Likes Received:
    1
    This is actually a sysctl value underneath the systemd configuration, in case that makes it easier. net.ipv6.conf.<interface>.accept_ra
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice