Separate disk partition for local-lvm?

ssspinball

New Member
May 19, 2022
4
1
3
My end goal is to move an existing VM from one node to a second and then permanently decommission the first node as it's on temporary hardware.

The first proxmox node was created bare metal from the proxmox USB installer without issue. I have now created a second node where I had to follow this wonderful guide to first install Debian 11 and then proxmox after in order to workaround an ATI Radeon video card that isn't supported by the proxmox USB installer.

So now I have a cluster that holds both nodes. The partition set up on the 2 nodes is different though, and that appears to impact functionality. I don't like the idea of deviating from the default config, so I'd kinda like to fix this to avoid both immediate and future issues. See attachments.

The disk layout differences that I noticed are:
  • The Debian installer created a 1GB swap partition
  • Proxmox installer created an EFI partition and the Debian installer did not
  • Debian installed node ended up with a single partition for everything in the node, whereas the proxmox installer created separate "local" and "local-lvm" partitions.
At first I thought this didn't matter, but the migration of the VM from the first node to the second fails with an error that local-lvm is missing (which is true).

So my questions are:
  1. Is it recommended (in general) to have a separate partition for local-lvm?
  2. If so, can I just use linux partition utilities (outside proxmox) to resize the partition and leave space for local-lvm?
  3. Can I delete the 1GB swap partition? I have already removed the debian kernel as instructed while installing proxmox on top of the debian install
  4. Does it matter that there's no EFI partition as long as the machine boots normally?
  5. Does it matter that the second node shows the main partition usage as "ext4" vs the first node that lists usage as "LVM"
Appreciate any guidance.
 

Attachments

  • Screen Shot 2022-05-25 at 11.22.19 AM.png
    Screen Shot 2022-05-25 at 11.22.19 AM.png
    48.4 KB · Views: 0
  • Nodes.jpg
    Nodes.jpg
    140.6 KB · Views: 0

ssspinball

New Member
May 19, 2022
4
1
3
Well I just took a crash course on LVM and related topics. :D

I have essentially manually created a LVM-thinpool on the new node and got everything working. I left the host system running on a (resized to be much smaller) ext4 partition.

I have the VM migration happening right now.
 
  • Like
Reactions: leesteken

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!