[SOLVED] RKHUNTER does not recognise common options

May 18, 2019
231
15
38
Varies
At the bottom of rkhunter.conf (I also tried placing it separately in rkhunter.conf.local), and after checking for invisible chars,

> Unknown configuration file option: CRON_DAILY_RUN="false"

> Unknown configuration file option: CRON_DB_UPDATE="true"

> Unknown configuration file option: APT_AUTOGEN="true"

Comes up for `rkhunter -C`. rkhunter is Version 1.4.6-5 from Maintainer: Debian Security Tools on Debian 10.1.

I already tried purging and reinstalling. Inserting other options in rkhunter.conf.local, such as `UPDATE_MIRRORS=1` or `ALLOW_SSH_ROOT_USER = yes`, does not trigger a warning. Only these three give issues.

PS: I say rkhunter.conf.local but it doesn't matter, the result is the same if I edit rkhunter.conf directly. All editing is done in nano, so there are no CRLF issues.
 
Hi,

Rootkit Hunter is not part of Proxmox VE.
So I would ask the Debian maintainer for help.
Or the source from where you got the package.
 
those three options need to be set in /etc/default/rkhunter.
 
glad to be of help. you can mark the thread as [SOLVED] so others know what to expect
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!