Restauration fails!

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Hello everyone,

Could you please help me!

I have a back up of a VM when I try to restore its original hypervisor it works fully fine but not to another proxmox hypervisor I get this error message:

restore vma archive: lzop -d -c /mnt/pve/SynoNFS/dump/vzdump-qemu-1000-2021_06_26-08_07_39.vma.lzo | vma extract -v -r /var/tmp/vzdumptmp22209.fifo - /var/tmp/vzdumptmp22209 CFG: size: 1247 name: qemu-server.conf CFG: size: 190 name: qemu-server.fw DEV: dev_id=1 size: 32426164224 devname: drive-virtio0 DEV: dev_id=2 size: 161061273600 devname: drive-virtio1 DEV: dev_id=3 size: 2147483648000 devname: drive-virtio2 DEV: dev_id=4 size: 1073741824000 devname: drive-virtio3 CTIME: Sat Jun 26 08:07:40 2021 new volume ID is 'hddpool:vm-100-cloudinit' new volume ID is 'hddpool:vm-100-disk-0' new volume ID is 'hddpool:vm-100-disk-1' new volume ID is 'hddpool:vm-100-disk-2' temporary volume 'hddpool:vm-100-disk-2' sucessfuly removed temporary volume 'hddpool:vm-100-disk-1' sucessfuly removed temporary volume 'hddpool:vm-100-disk-0' sucessfuly removed no lock found trying to remove 'create' lock TASK ERROR: command 'set -o pipefail && lzop -d -c /mnt/pve/SynoNFS/dump/vzdump-qemu-1000-2021_06_26-08_07_39.vma.lzo | vma extract -v -r /var/tmp/vzdumptmp22209.fifo - /var/tmp/vzdumptmp22209' failed: zfs error: cannot create 'hddpool/vm-100-disk-3': [B]out of space[/B]


I have really more than enough of space:

1625864229129.png

Could you please tell me why I got this error??!!

Thank you very much for any help.

Best regards,
Yaseen
 
Last edited:

Stefan_R

Proxmox Staff Member
Staff member
Jun 4, 2019
1,300
276
88
Vienna
Can you post the output of 'df -h' as well as 'zfs list' on your PVE host? It might be the root disk getting full?
 
  • Like
Reactions: YaseenKamala

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Hello @Stefan_R thank you so much for you reply,

Please see bellow the output for 'df -h' as requested.

1626362220438.png

and zfs list output:
1626353964323.png


Again thank you so much for your support!

Have a nice day.
 
Last edited:

Stefan_R

Proxmox Staff Member
Staff member
Jun 4, 2019
1,300
276
88
Vienna
Hm, how big is the backup? Can you try to copy it to the local disk first and then restore it with qmrestore <archive> <vmid>?
 

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Hm, how big is the backup? Can you try to copy it to the local disk first and then restore it with qmrestore <archive> <vmid>?
@Stefan_R It's about 1.5 TB and since it's already backed up to a Synology NAS which is shared between 2 ProxMox servers and When I try to restore it to it's original server the restore works fully normal but not to a different one!!? Could you please tell me what will be the difference if I copy it to a local disk while the Synology NAS is already local DISK for both servers?
1626362007566.png
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!