1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Recovered from crash node / vms using venet not working

Discussion in 'Proxmox VE: Installation and configuration' started by Chris Rivera, Feb 11, 2013.

  1. Chris Rivera

    Chris Rivera Member

    Joined:
    Jul 25, 2012
    Messages:
    197
    Likes Received:
    0
    Don't mean to repost but I figured its a new issue i am having and other users might have. They can find resolution on this post when searching in google.

    #####

    I was able to finally

    1. mount the pve lvm
    2. extract pve-data using tar
    3. untar the file on node 3.
    4. Copy config files so proxmox knows vms are on node 3
    5. booted vms.

    all vps with veth work just fine...

    all vms with venet have no incoming or out going connections and can only ping main host node.

    How to i get proxmox to remake all venet network routing?



    VM ifconfig:

    [root@VM760 /]# ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:16 errors:0 dropped:0 overruns:0 frame:0
    TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1468 (1.4 KiB) TX bytes:1468 (1.4 KiB)


    venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:127.0.0.1 P-t-P:127.0.0.1 Bcast:0.0.0.0 Mask:255.255.255.255
    UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
    RX packets:5 errors:0 dropped:0 overruns:0 frame:0
    TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:420 (420.0 b) TX bytes:865 (865.0 b)


    venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:199.195.213.*** P-t-P:199.195.213.*** Bcast:199.195.213.*** Mask:255.255.255.255
    UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1


    venet0:1 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:199.195.214.*** P-t-P:199.195.214.*** Bcast:199.195.214.*** Mask:255.255.255.255
    UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1



    #############


    vm route:

    [root@VM760 /]# route

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    169.254.0.0 * 255.255.0.0 U 0 0 0 venet0
    default * 0.0.0.0 U 0 0 0 venet0




    #############


    hostnode ifconfig:

    root@proxmox3a:~# ifconfig | grep 760


    #############​

    Last edited by Chris Rivera; 40 Minutes Ago at 05:41 PM.​
     
  2. Chris Rivera

    Chris Rivera Member

    Joined:
    Jul 25, 2012
    Messages:
    197
    Likes Received:
    0
    {SOLVED}

    forgot to update vz.conf file

    i edited the file to ping the arp
     
  3. udo

    udo Well-Known Member
    Proxmox VE Subscriber

    Joined:
    Apr 22, 2009
    Messages:
    4,567
    Likes Received:
    27
    Hi,
    only an remark - with rsync you will be much faster, then with tar -c + tar -x.

    Udo
     

Share This Page