qmp command 'backup' failed

speedlnx

Active Member
Feb 7, 2016
36
1
28
41
Hello, if i run manual backup (via the vm web menu) I can do incremental backup in my PBS server without any problem. Mode snapshot.

Code:
INFO: starting new backup job: vzdump 123 --remove 0 --mode snapshot --storage c03 --node cloud03-hz
INFO: Starting Backup of VM 123 (qemu)
INFO: Backup started at 2020-09-23 18:54:34
INFO: status = running
INFO: VM Name: XXXXX
INFO: include disk 'scsi0' 'vms:123/vm-123-disk-0.qcow2' 8G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/123/2020-09-23T16:54:34Z'
INFO: issuing guest-agent 'fs-freeze' command
INFO: enabling encryption
INFO: issuing guest-agent 'fs-thaw' command
INFO: started backup task '5dbb216c-8a45-431f-8766-ec0bfa6df326'
INFO: resuming VM again
INFO: scsi0: dirty-bitmap status: created new
INFO:   3% (256.0 MiB of 8.0 GiB) in  3s, read: 85.3 MiB/s, write: 68.0 MiB/s
INFO:   5% (440.0 MiB of 8.0 GiB) in  6s, read: 61.3 MiB/s, write: 61.3 MiB/s
INFO:   6% (556.0 MiB of 8.0 GiB) in  9s, read: 38.7 MiB/s, write: 38.7 MiB/s
INFO:   9% (772.0 MiB of 8.0 GiB) in 12s, read: 72.0 MiB/s, write: 72.0 MiB/s
INFO:  11% (972.0 MiB of 8.0 GiB) in 15s, read: 66.7 MiB/s, write: 66.7 MiB/s
INFO:  14% (1.1 GiB of 8.0 GiB) in 18s, read: 62.7 MiB/s, write: 62.7 MiB/s
INFO:  16% (1.3 GiB of 8.0 GiB) in 21s, read: 69.3 MiB/s, write: 69.3 MiB/s
INFO:  18% (1.5 GiB of 8.0 GiB) in 24s, read: 61.3 MiB/s, write: 56.0 MiB/s
INFO:  27% (2.2 GiB of 8.0 GiB) in 27s, read: 228.0 MiB/s, write: 86.7 MiB/s
INFO:  43% (3.5 GiB of 8.0 GiB) in 30s, read: 454.7 MiB/s, write: 69.3 MiB/s
INFO:  46% (3.7 GiB of 8.0 GiB) in 33s, read: 62.7 MiB/s, write: 62.7 MiB/s
INFO:  48% (3.9 GiB of 8.0 GiB) in 36s, read: 62.7 MiB/s, write: 61.3 MiB/s
INFO:  51% (4.1 GiB of 8.0 GiB) in 39s, read: 90.7 MiB/s, write: 68.0 MiB/s
INFO:  54% (4.3 GiB of 8.0 GiB) in 42s, read: 61.3 MiB/s, write: 61.3 MiB/s
INFO:  56% (4.5 GiB of 8.0 GiB) in 45s, read: 68.0 MiB/s, write: 68.0 MiB/s
INFO:  58% (4.7 GiB of 8.0 GiB) in 48s, read: 61.3 MiB/s, write: 61.3 MiB/s
INFO:  61% (4.9 GiB of 8.0 GiB) in 51s, read: 65.3 MiB/s, write: 65.3 MiB/s
INFO:  63% (5.1 GiB of 8.0 GiB) in 54s, read: 65.3 MiB/s, write: 65.3 MiB/s
INFO:  65% (5.3 GiB of 8.0 GiB) in 57s, read: 64.0 MiB/s, write: 60.0 MiB/s
INFO:  68% (5.5 GiB of 8.0 GiB) in  1m  0s, read: 68.0 MiB/s, write: 62.7 MiB/s
INFO:  70% (5.7 GiB of 8.0 GiB) in  1m  3s, read: 62.7 MiB/s, write: 62.7 MiB/s
INFO:  73% (5.9 GiB of 8.0 GiB) in  1m  6s, read: 76.0 MiB/s, write: 74.7 MiB/s
INFO:  77% (6.2 GiB of 8.0 GiB) in  1m  9s, read: 116.0 MiB/s, write: 65.3 MiB/s
INFO:  80% (6.4 GiB of 8.0 GiB) in  1m 12s, read: 77.3 MiB/s, write: 77.3 MiB/s
INFO:  83% (6.7 GiB of 8.0 GiB) in  1m 15s, read: 76.0 MiB/s, write: 76.0 MiB/s
INFO:  85% (6.9 GiB of 8.0 GiB) in  1m 18s, read: 66.7 MiB/s, write: 66.7 MiB/s
INFO:  88% (7.0 GiB of 8.0 GiB) in  1m 21s, read: 61.3 MiB/s, write: 54.7 MiB/s
INFO:  90% (7.3 GiB of 8.0 GiB) in  1m 24s, read: 73.3 MiB/s, write: 48.0 MiB/s
INFO:  93% (7.5 GiB of 8.0 GiB) in  1m 27s, read: 66.7 MiB/s, write: 58.7 MiB/s
INFO:  95% (7.6 GiB of 8.0 GiB) in  1m 30s, read: 61.3 MiB/s, write: 58.7 MiB/s
INFO:  98% (7.9 GiB of 8.0 GiB) in  1m 33s, read: 81.3 MiB/s, write: 58.7 MiB/s
INFO: 100% (8.0 GiB of 8.0 GiB) in  1m 35s, read: 64.0 MiB/s, write: 30.0 MiB/s
INFO: backup is sparse: 1.84 GiB (22%) total zero data
INFO: backup was done incrementally, reused 2.12 GiB (26%)
INFO: transferred 8.00 GiB in 95 seconds (86.2 MiB/s)
INFO: Finished Backup of VM 123 (00:01:35)
INFO: Backup finished at 2020-09-23 18:56:09
INFO: Backup job finished successfully
TASK OK

If I run the same backup from the proxmox scheduler it fail with:

Code:
INFO: starting new backup job: vzdump 123 --storage c03 --mailnotification always --compress zstd --mailto xxx@xxx.xxx --quiet 1 --mode snapshot
INFO: Starting Backup of VM 123 (qemu)
INFO: Backup started at 2020-09-23 19:03:02
INFO: status = running
INFO: VM Name: XXXXX
INFO: include disk 'scsi0' 'vms:123/vm-123-disk-0.qcow2' 8G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/123/2020-09-23T17:03:02Z'
INFO: issuing guest-agent 'fs-freeze' command
INFO: enabling encryption
INFO: issuing guest-agent 'fs-thaw' command
ERROR: VM 123 qmp command 'backup' failed - backup register image failed: command error: no previous backup found, cannot do incremental backup
ERROR: Backup of VM 123 failed - VM 123 qmp command 'backup' failed - backup register image failed: command error: no previous backup found, cannot do incremental backup
INFO: Failed at 2020-09-23 19:03:03
INFO: Backup job finished with errors

TASK ERROR: job errors


Proxmox Backup Server 0.8.19-1

Proxmox Server:

proxmox-ve: 6.2-2 (running kernel: 5.4.55-1-pve)
pve-manager: 6.2-11 (running version: 6.2-11/22fb4983)
pve-kernel-5.4: 6.2-7
pve-kernel-helper: 6.2-7
pve-kernel-5.4.65-1-pve: 5.4.65-1
pve-kernel-5.4.60-1-pve: 5.4.60-2
pve-kernel-5.4.55-1-pve: 5.4.55-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.4-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
libjs-extjs: 6.0.1-10
libknet1: 1.16-pve1
libproxmox-acme-perl: 1.0.5
libpve-access-control: 6.1-2
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.2-2
libpve-guest-common-perl: 3.1-3
libpve-http-server-perl: 3.0-6
libpve-storage-perl: 6.2-6
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.3-1
lxcfs: 4.0.3-pve3
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.2-12
pve-cluster: 6.1-8
pve-container: 3.2-1
pve-docs: 6.2-5
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-2
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-1
pve-qemu-kvm: 5.1.0-2
pve-xtermjs: 4.7.0-2
qemu-server: 6.2-14
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 0.8.4-pve1
 

Dominic

Proxmox Staff Member
Staff member
Mar 18, 2019
1,388
168
68
If I run the same backup from the proxmox scheduler it fail with:
You mean a backup job in Proxmox VE? Backup jobs are basically cron jobs. You can check the exact command that gets executed using
Code:
cat /etc/pve/vzdump.cron
Of course, the exact command is also in the logs, so you could copy&paste that too, to recreate the problem.

Is it a copy & paste error, that the backup client is not on your Proxmox VE? What is the following?
Code:
pveversion -v | grep backup-client
 

speedlnx

Active Member
Feb 7, 2016
36
1
28
41
Hello, as you can see in the logs I post before the command is almost the same

Code:
root@********~ # pveversion -v | grep backup-client
proxmox-backup-client: 0.9.0-1
root@******** ~ #
 

speedlnx

Active Member
Feb 7, 2016
36
1
28
41
Still problems with some vm (4 on a total of more then 20).


Code:
INFO: Starting Backup of VM 100 (qemu)
INFO: Backup started at 2020-12-20 05:30:02
INFO: status = running
INFO: VM Name: TargetCross-SQL
INFO: include disk 'virtio0' 'backup:100/vm-100-disk-0.qcow2' 80G
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/100/2020-12-20T04:30:02Z'
INFO: issuing guest-agent 'fs-freeze' command
INFO: enabling encryption
INFO: issuing guest-agent 'fs-thaw' command
ERROR: VM 100 qmp command 'backup' failed - backup register image failed: command error: no previous backup found, cannot do incremental backup
INFO: aborting backup job
ERROR: Backup of VM 100 failed - VM 100 qmp command 'backup' failed - backup register image failed: command error: no previous backup found, cannot do incremental backup
INFO: Failed at 2020-12-20 05:30:11


proxmox-backup-client: 1.0.6-1

Package: proxmox-backup-server
Version: 1.0.6-1
 
Last edited:

speedlnx

Active Member
Feb 7, 2016
36
1
28
41
No one has the same problem? If I delete all the backups from the PBS server the first backup works like a charm, the second one break with the same error.

Client

proxmox-ve: 6.3-1 (running kernel: 5.4.73-1-pve)
pve-manager: 6.3-6 (running version: 6.3-6/2184247e)
pve-kernel-5.4: 6.3-8
pve-kernel-helper: 6.3-8
pve-kernel-5.4.106-1-pve: 5.4.106-1
pve-kernel-5.4.98-1-pve: 5.4.98-1
pve-kernel-5.4.73-1-pve: 5.4.73-1
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.1.0-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 3.0.0-1+pve3
libjs-extjs: 6.0.1-10
libknet1: 1.20-pve1
libproxmox-acme-perl: 1.0.8
libproxmox-backup-qemu0: 1.0.3-1
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.1-3
libpve-common-perl: 6.3-5
libpve-guest-common-perl: 3.1-5
libpve-http-server-perl: 3.1-1
libpve-storage-perl: 6.3-7
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.6-2
lxcfs: 4.0.6-pve1
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.12-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.4-9
pve-cluster: 6.2-1
pve-container: 3.3-4
pve-docs: 6.3-1
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.2-2
pve-ha-manager: 3.1-1
pve-i18n: 2.3-1
pve-qemu-kvm: 5.2.0-5
pve-xtermjs: 4.7.0-3
qemu-server: 6.3-10
smartmontools: 7.2-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 2.0.4-pve1

Server

Proxmox Backup server: 1.0-11


First backup

Code:
INFO: starting new backup job: vzdump 102 --storage c03 --remove 0 --mode snapshot --node cloud03-hz
INFO: Starting Backup of VM 102 (qemu)
INFO: Backup started at 2021-04-04 16:02:58
INFO: status = running
INFO: VM Name: chr-04
INFO: include disk 'virtio0' 'vms:102/vm-102-disk-0.qcow2' 128M
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/102/2021-04-04T14:02:58Z'
INFO: issuing guest-agent 'fs-freeze' command
INFO: enabling encryption
INFO: issuing guest-agent 'fs-thaw' command
INFO: started backup task 'df32be40-32c0-4f4d-872c-80bbd7c27b06'
INFO: resuming VM again
INFO: virtio0: dirty-bitmap status: existing bitmap was invalid and has been cleared
INFO: 100% (128.0 MiB of 128.0 MiB) in 2s, read: 64.0 MiB/s, write: 60.0 MiB/s
INFO: backup is sparse: 8.00 MiB (6%) total zero data
INFO: backup was done incrementally, reused 8.00 MiB (6%)
INFO: transferred 128.00 MiB in 2 seconds (64.0 MiB/s)
INFO: Finished Backup of VM 102 (00:00:02)
INFO: Backup finished at 2021-04-04 16:03:00
INFO: Backup job finished successfully
TASK OK

Second backup

Code:
INFO: starting new backup job: vzdump 102 --storage c03 --node cloud03-hz --remove 0 --mode snapshot
INFO: Starting Backup of VM 102 (qemu)
INFO: Backup started at 2021-04-04 16:03:11
INFO: status = running
INFO: VM Name: chr-04
INFO: include disk 'virtio0' 'vms:102/vm-102-disk-0.qcow2' 128M
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: creating Proxmox Backup Server archive 'vm/102/2021-04-04T14:03:11Z'
INFO: issuing guest-agent 'fs-freeze' command
INFO: enabling encryption
INFO: issuing guest-agent 'fs-thaw' command
ERROR: VM 102 qmp command 'backup' failed - backup register image failed: command error: no previous backup found, cannot do incremental backup
INFO: aborting backup job
ERROR: Backup of VM 102 failed - VM 102 qmp command 'backup' failed - backup register image failed: command error: no previous backup found, cannot do incremental backup
INFO: Failed at 2021-04-04 16:03:12
INFO: Backup job finished with errors
TASK ERROR: job errors
 
Last edited:

Dominic

Proxmox Staff Member
Staff member
Mar 18, 2019
1,388
168
68

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!