qemu lzo backup ok, restore corrupt, CIFS Share

WHSProxmox

Member
Dec 30, 2018
17
0
6
57
Hello experts,

I'm going with proxmox for several months. LXC and quemu guests. The backup storage is smb mounted from a windows Server 2016 Essentials with well proven mirrord storage.

Observation:
  • LXC backup with lzo was never a proble => restore always ok
  • QEMU backup with lzo has worked always
  • QEMU restore
    • has worked for three windows guests (2x Server 2016, 1x win10 guest) after installation of the guests for some months
    • Now all three guests on two different servers fail during restore: lzo corrupt
    • When switching compression to gzip restore is always ok!
Perhaps this is an size issue?: Backups are between 13-25 GB.

Hole system PVE and guests running verry stable.

Last apt dist-upgrade: 2019-02-03
proxmox-ve: 5.3-1 (running kernel: 4.15.18-10-pve)
pve-manager: 5.3-8 (running version: 5.3-8/2929af8e)
pve-kernel-4.15: 5.3-1
pve-kernel-4.15.18-10-pve: 4.15.18-32
pve-kernel-4.15.18-9-pve: 4.15.18-30
pve-kernel-4.15.18-7-pve: 4.15.18-27
corosync: 2.4.4-pve1 criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-43
libpve-guest-common-perl: 2.0-19
libpve-http-server-perl: 2.0-11
libpve-storage-perl: 5.0-36
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-2
lxcfs: 3.0.2-2
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-22
pve-cluster: 5.0-33
pve-container: 2.0-33
pve-docs: 5.3-1
pve-edk2-firmware: 1.20181023-1
pve-firewall: 3.0-17
pve-firmware: 2.0-6
pve-ha-manager: 2.0-6
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-1
pve-qemu-kvm: 2.12.1-1
pve-xtermjs: 3.10.1-1
qemu-server: 5.0-45
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.12-pve1~bpo1

best regards

Lars
 
Seems to be a problem with the backup storage or server. Either a problem with the used HD or maybe a RAM problem ....

Maybe you can test backup using a different storage?
 
Thanks for the fast suggestion. It's hard to belive, cause the disks are mirrored, there are abount 1 TB of server essentails windows cleint backups. A hard disk on the storage is used for windows server backup of the Win Srv 2016 guest. Restore was always fine from that disks.
 
Do some testing. No clue so far. Most often fail on the Server Essentials even without the mirroring with share on physical disk.

Success on another Computer, but also failure.

gzip backup is ok on Server Essential restore ok and guest running.

Will se if I can improve testing, especially with scheduled backup, or stay with gzip.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!