QEMU-Guest Fails to install

bensode

Member
Jan 9, 2019
61
4
13
51
Harrisburg, PA
Good afternoon. I have a couple of servers that the QEMU-Guest agent fails to install from the virtio-1.190 release. If I attempt to install it from the guest-agent subdirectory I get "QEMU guest agent" window with message "There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor". If I attempt to install the virtio-win-guest-tools at the root of the release, it completes the first half and fails at the spice and guest-agent service installation and rolls back the entire installation. The command prompt pops up momentarily and then closes with a "Setup Failed" window with "One or more issues caused the setup to fail. Please fix the issues and then retry setup. For more information see the log file. 0x80070643 - Fatal error during installation."

Have tried rebooting, re-installing and making sure the service didn't already exist then rebooting and trying again. Kind of stuck and would really like to have all of the virtio drivers and the agent installed but not having any luck with 3 particular Windows 2012 R2 servers. We have installed on many other servers with no issues. I've attached the logs and screenshots of the errors. Most notable entry from the log is pasted below.

[0E44:0708][2021-03-16T12:57:35]i301: Applying execute package: vwi.vxX9, action: Install, path: C:\ProgramData\Package Cache\{BBB1A253-8C7C-49C0-8378-AF8CBED116C3}v101.2.0\vwi.vxX9, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7"' [0E44:0708][2021-03-16T12:57:39]e000: Error 0x80070643: Failed to install MSI package. [0E44:0708][2021-03-16T12:57:39]e000: Error 0x80070643: Failed to execute MSI package. [0F00:0A94][2021-03-16T12:57:39]e000: Error 0x80070643: Failed to configure per-machine MSI package.
 

Attachments

  • Virtio-win-guest-tools_20210316125726.log
    20 KB · Views: 9
  • qemu-agent-error.png
    qemu-agent-error.png
    26.5 KB · Views: 24
  • virtio-error.png
    virtio-error.png
    25 KB · Views: 22
  • not running.png
    not running.png
    9.8 KB · Views: 22

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,009
632
118

bensode

Member
Jan 9, 2019
61
4
13
51
Harrisburg, PA
hi,


* have you seen [0] and [1]?

* can you also post your vm configuration? qm config VMID

* is the installer running as administrator?

[0]: https://pve.proxmox.com/wiki/Windows_2012_guest_best_practices
[1]: https://pve.proxmox.com/wiki/Windows_VirtIO_Drivers
Yes have seen [0] and [1].

Code:
agent: 1
balloon: 0
bootdisk: scsi0
cores: 4
cpu: host
hotplug: disk,network,memory,cpu
ide2: none,media=cdrom
memory: 24576
name: PRDSQL1B
net0: virtio=06:F0:FD:18:85:C0,bridge=vmbr0,tag=172
numa: 1
ostype: win8
scsi0: PRDPOOL01:vm-501-disk-0,discard=on,size=80G
scsi1: disk14b_encrypted:vm-501-disk-0,backup=0,discard=on,size=550G
scsi2: disk3b_encrypted:vm-501-disk-0,backup=0,discard=on,size=200G
scsihw: virtio-scsi-pci
smbios1: uuid=daa8f2eb-ba3c-4a22-a62c-52fe24a8de99
sockets: 1
vmgenid: e7d1de0e-9509-4691-91f6-a4f2350bd84b

Ran the installer as local Administrator and Domain Administrator with same results.
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,009
632
118
from [0]:
For the VirtIO drivers, upload the driver ISO (use the stable VirtIO ISO, get it from here) to your storage, create a new CDROM drive (use "Add -> CD/DVD drive" in the hardware tab) with Bus "IDE" and number 3. Load the Virtio Drivers ISO in the new virtual CDROM drive.


but i don't see the virtio iso attached to your machine. could you try that?

the links on that page are quite a bit to follow but you can download the iso from here [0]

[0]: https://github.com/virtio-win/virtio-win-pkg-scripts/blob/master/README.md
 

bensode

Member
Jan 9, 2019
61
4
13
51
Harrisburg, PA
I think we have a disconnect with the issue. The problem isn't an inability to attach the ISO -- the problem is that when we attach and run through the installation, it fails at the guest-agent. If we attempt to install the guest-agent directly, it also fails. I provided the screen caps as attachments and provided the logs.
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,009
632
118
could you try to restart the VM and run the installer again?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,009
632
118
i'm unable to reproduce this issue here. could you post pveversion -v output?
 

Wyk72

New Member
Aug 2, 2021
6
0
1
50
After a BIG struggle with this issue, I've found that sometimes, for obscure reasons, the installer of the guest agent spews out an error like:


Error: 8004E00F when trying to access COM+ Applications in Component Services

I solved this obscure issue as per Microsoft reccomendation:

------------------- CUT HERE

This error could be because of missing or damaged MS DTC or the Network Service account does not have sufficient permissions.

We can try the steps mentioned below and check if that helps in resolving the issue:

Method 1: Re-create the MS DTC log

Re-create the MS DTC log, and then restart the service. To do this, follow these steps:
  1. Type Command Prompt in the search bar on the taskbar.
  2. Right click on Command Prompt icon and click on Run as administrator.
  3. At the Command Prompt, type the following command, and then press ENTER: msdtc –resetlog
    Warning
    The msdtc -resetlog command can cause data corruption if it is used incorrectly. Make sure that you do not have any pending transactions when you run this command.
  4. Type the following command, and then press ENTER: net start msdtc.

If Method 1 didn’t help, please follow Method 2.

Method 2: Re-registering the service




Note:
Important this section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.




Follow the steps to take backup of registry.




  1. Press the Windows logo key + R to open the Run dialog box.
  2. Type regedit in the Run dialog box, then press Enter.
  3. Navigate to the location: HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC
  4. Right click on TurnOffRpcSecurity and select modify. Change the value to 1.
  5. Now, in Run box, type services.msc.
  6. Look for Distributed Transaction Coordinator and stop the service.
  7. Double click on the service and click on Log On tab.
  8. Now type NT Authority\NetworkService under This account.
  9. Leave the password section blank.
  10. Click on Apply and OK.
  11. Start the service.
  12. Restart the computer.
--------------- CUT HERE

The "Method 1" worked for me, after the commands "msdtc –resetlog" & "net start msdtc" the guest-agent installed correctly. YMMV.

Took me 1 hour of swearing at the screen to get the gist of this error, because the cmd prompt that spews out the error lasts for less than half a second. I had to record the screen and slow it down to 0.02X .

It was painful.

 

bensode

Member
Jan 9, 2019
61
4
13
51
Harrisburg, PA
After a BIG struggle with this issue, I've found that sometimes, for obscure reasons, the installer of the guest agent spews out an error like:


Error: 8004E00F when trying to access COM+ Applications in Component Services

I solved this obscure issue as per Microsoft reccomendation:

------------------- CUT HERE

This error could be because of missing or damaged MS DTC or the Network Service account does not have sufficient permissions.

We can try the steps mentioned below and check if that helps in resolving the issue:

Method 1: Re-create the MS DTC log

Re-create the MS DTC log, and then restart the service. To do this, follow these steps:
  1. Type Command Prompt in the search bar on the taskbar.
  2. Right click on Command Prompt icon and click on Run as administrator.
  3. At the Command Prompt, type the following command, and then press ENTER: msdtc –resetlog
    Warning
    The msdtc -resetlog command can cause data corruption if it is used incorrectly. Make sure that you do not have any pending transactions when you run this command.
  4. Type the following command, and then press ENTER: net start msdtc.

If Method 1 didn’t help, please follow Method 2.

Method 2: Re-registering the service




Note:
Important this section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.




Follow the steps to take backup of registry.




  1. Press the Windows logo key + R to open the Run dialog box.
  2. Type regedit in the Run dialog box, then press Enter.
  3. Navigate to the location: HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC
  4. Right click on TurnOffRpcSecurity and select modify. Change the value to 1.
  5. Now, in Run box, type services.msc.
  6. Look for Distributed Transaction Coordinator and stop the service.
  7. Double click on the service and click on Log On tab.
  8. Now type NT Authority\NetworkService under This account.
  9. Leave the password section blank.
  10. Click on Apply and OK.
  11. Start the service.
  12. Restart the computer.
--------------- CUT HERE

The "Method 1" worked for me, after the commands "msdtc –resetlog" & "net start msdtc" the guest-agent installed correctly. YMMV.

Took me 1 hour of swearing at the screen to get the gist of this error, because the cmd prompt that spews out the error lasts for less than half a second. I had to record the screen and slow it down to 0.02X .

It was painful.
Thank you for this will give it a shot if it happens again.
 

asifhp

New Member
Apr 28, 2022
2
1
3
KVM Guest
OS: Windows 10 Enterprise
Version: 21H2
Build: 19044.1526
Windows Feature Experience Pack: 120.2212.4170.0

Virtio tools for Windows ISO
virtio-win-0.1.217-1 : FAIL (Does not install.)
virtio-win-0.1.215-2 : PASS (The Installation starts the vdagent and qemu-ga services automatically.)

Services Commands
"C:\Program Files\Spice Agent\vdagent.exe"
"C:\Program Files\Qemu-ga\qemu-ga.exe" -d --retry-path
1651275804233.png

What works?
HOST ─▶ Copy-and-paste ─▶ GUEST :
PASS
GUEST ─▶ Copy-and-paste ─▶ HOST : FAIL (Not sure why this fails to work.)
 
Last edited:

asifhp

New Member
Apr 28, 2022
2
1
3
I do not understand the order how does this gets activated?
should we install the agent then activate it ?
Please see my updated previous message.
If the services do not automatically start, then try starting them. It might fail, so then you need to consider installing an older version of the virtio-win package.
 
Last edited:
  • Like
Reactions: rifaterdemsahin

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!