[SOLVED] PVE7, Shutdown/Reboot kein Consolen Log.

Feb 12, 2019
117
8
23
47
schabau.eu
Hallo,

Seit PVE7 habe ich keinerlei Ausgaben auf dem Monitor, wenn ich einen Reboot oder Shutdown von PVE durchführe.
Der Monitor bleibt komplett schwarz, die Shutdown-Meldungen der einzelnen Dienste bleiben alle aus, bis irgend wann wieder der BIOS auftaucht.

Werden die Meldungen irgend wo hin umgeleitet?
Beim booten sehe ich die üblichen Meldungen.

Der Loglevel ist unverändert wie bei PVE6.
root@Proxmox:~# cat /proc/sys/kernel/printk 4 4 1 7

Viele Grüße
Detlef Paschke
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,956
814
163
33
Vienna
wird die boot grafikkarte vielleicht an eine vm durchgereicht oder ähnliches?
 
Feb 12, 2019
117
8
23
47
schabau.eu
wird die boot grafikkarte vielleicht an eine vm durchgereicht oder ähnliches?
Hallo,

nein, oder zumindest habe ich in der Richtung nie etwas gemacht.

Ich hatte früher in der Grub Config ein paar Anpassungen gemacht.
Das sind die aktiven Punkte in /etc/default/grub

Code:
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Proxmox Virtual Environment"
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="GFXPAYLOAD=text nomodeset"

...

GRUB_DISABLE_OS_PROBER=true

...

GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=keep

...

GRUB_DISABLE_RECOVERY="true"

Da hat sich zwischen den Versionen nie etwas geändert.

Beim Reboot sehe ich auf dem Monitor (oder per IPMI auf einer iKVM-Console) nur noch einen traurig blinkenden Cursor oben links in der Ecke, bis irgend wann das Supermicro-Loge des Bios wieder erscheint.
Es gibt keine Meldung vom Shutdown der VMs und danach auch nicht vom beenden der einzelnen Dienste.

Viele Grüße
Detlef Paschke
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,956
814
163
33
Vienna
das ist das 'quiet' von der grub config. ist allerdings hier schon bei buster so?
 
Feb 12, 2019
117
8
23
47
schabau.eu
das ist das 'quiet' von der grub config. ist allerdings hier schon bei buster so?

Hallo,

wenn ich 'quiet' raus nehme, werde ich natürlich beim Start wie auch beim Shutdown/Reboot zugeschiss... mit Meldungen.
Bei PVE5 und PVE6 war 'quiet' aber auch schon gesetzt und da hat man auf dem Monitor beim Reboot oder Shutdown eine Meldung wie "A stop job is running...." gesehen bis alle VMs heruntergefahren waren und danach die Statusmeldungen, dass ein Dienst nach dem anderen geschlossen wurde.

Aktuell sehe ich hier beim Shutdown/Reboot Garnichts mehr. Das ist mir etwas wenig.

Viele Grüße
Detlef Paschke
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,956
814
163
33
Vienna
ok hab jetzt ein bisschen gesucht und folgendes gefunden:

systemd hat seit 245:

* systemd/PID 1 accepts a new "systemd.show-status=error" setting, and
"quiet" has been changed to imply that instead of
"systemd.show-status=auto". In this mode, only messages about errors
and significant delays in boot are shown on the console.

man kann das wieder zurück auf 'auto' setzen entweder über die kernel cmdline mit 'systemd.show_status=auto' oder in der /etc/systemd/system.conf (ShowStatus=auto)

für eine genauere beschreibung der optionen siehe 'man systemd'
 
Feb 12, 2019
117
8
23
47
schabau.eu
ok hab jetzt ein bisschen gesucht und folgendes gefunden:

...

man kann das wieder zurück auf 'auto' setzen entweder über die kernel cmdline mit 'systemd.show_status=auto' oder in der /etc/systemd/system.conf (ShowStatus=auto)

Hallo Dominik,

das wäre im Grunde genau das was mir fehlt.
Da ich nur einen kleinen privaten Server betreibe, ist ein Test schnell gemacht. Von ein paar Minuten down, wird das weltweite Finanzsystem nicht zusammenbrechen. ;)

Ich habe hier folgendes Problem beobachtet:
Unabhängig davon, ob ich in /etc/systemd/system.conf die Raute vor ShowStatus nur entferne, sprich die Option "yes" belasse oder, wie von Dir vorgeschlagen, als Option "auto" anstelle "yes" verwende, werden in der Folge alle VMs bei mir nicht mehr sauber Heruntergefahren sondern bei einem reboot von Proxmox, "brutal" abgeschossen.
Wird die Option ShowStatus in /etc/systemd/system.conf wieder auskommentiert, werden alle VMs sauber nacheinander heruntergefahren bevor Proxmox selbst heruntergefahren wird.

Es handelt sich ausschließlich um Linux-VMs.

Viele Grüße
Detlef Paschke
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,956
814
163
33
Vienna
mhmm... würde mich wunder wenn die einstellung irgendeinen einfluss darauf hat..
aber kannst du mal die jeweiligen logs (journal/syslog) schicken? vielleicht sieht man ja was
 
Feb 12, 2019
117
8
23
47
schabau.eu
aber kannst du mal die jeweiligen logs (journal/syslog) schicken? vielleicht sieht man ja was
Ich habe versucht das Log soweit wie Möglich einzukürzen um es nicht zu übertreiben.
Es sollten die 3 letzten Starts enthalten sein. Beim ersten Start war ShowStatus noch aktiviert. Dann wurde ShowStatus auskommentiert und es folgte ein Reboot. Da wurde die VM noch abgeschossen. (Ich hatte nur noch VM100 im Autostart).
Beim folgenden Start mit auskommentierter Option ShowStatus, wurde die VM beim späteren Reboot ordentlich heruntergefahren. Der letze Start im Log ist das, was aktuell hier läuft.

Viele Grüße
Detlef Paschke
 

Attachments

  • syslog.log
    588.7 KB · Views: 2

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,956
814
163
33
Vienna
also das sieht mir nach einer falschen fährte aus...

beim 1. boot im syslog von 12:55 - 13:05 wurde der reboot schon initiiert, da war der service der für das starten/stoppen verantwortlich(pve-guets) ist noch gar nicht fertig (AFAICS der reboot wurde um ~13:02:57 initiert und pve-guests wurde mit dem starten um ~13:02:58 fertig)

in so einem fall kann es vielleicht passieren dass er nicht richtig gestoppt wird (und dann räumt systemd potentiell die gäste auf)

im 2. boot war pve-guests um 13:08:38 fertig und der reboot kam um ~13:08:54
 
Feb 12, 2019
117
8
23
47
schabau.eu
beim 1. boot im syslog von 12:55 - 13:05 wurde der reboot schon initiiert, da war der service der für das starten/stoppen verantwortlich(pve-guets) ist noch gar nicht fertig (AFAICS der reboot wurde um ~13:02:57 initiert und pve-guests wurde mit dem starten um ~13:02:58 fertig)

Hallo,

da kann ich auch noch mal eine neue "Testreihe" machen.
Evtl. hatte ich bei diesem Reboot nicht gewartet, bis der Kreisel vor "Start all VMs" verschwunden ist. Bei anderen Starts aber sehr wohl. Da hatte ich noch alle VM im Autostart und ewig warten müssen, bis alle gestartet waren.

Viele Grüße
Detlef Paschke
 
Feb 12, 2019
117
8
23
47
schabau.eu
in so einem fall kann es vielleicht passieren dass er nicht richtig gestoppt wird (und dann räumt systemd potentiell die gäste auf)
Hallo,

ich habe noch mal eine Testreihe gemacht und dieses mal länger vor dem Reboot gewartet.
Dieses mal wurden alle VMs nacheinander, so wie Konfiguriert, heruntergefahren.

Die ideale Konfiguration für mich ist ShowStatus=yes in in /etc/systemd/system.conf. So bekomme ich die Informationen, die ich haben möchte.
In /etc/sysctl.conf habe ich kernel.printk = 4 4 1 7 festgelegt, dass ist soweit ich weiß zwar auch der Standard, sollte der aber mal verändert werden, bleibt es dadurch bei mir unverändert.

Frage am Rand.
In den Logdateien sieht eine Meldung z.B. so aus:
Dec 2 10:40:10 proxmox kernel: [ 320.451543] kvm [2536]: ...
Auf der Console sieht die selbe Meldung so aus:
[ 320.451543] kvm [2536]: ...

Es wird auf der Console also nur der UNIX-Timestamp angegeben, in den Logdateien auch eine "lesbare" Zeit.
Lässt sich irgendwo Konfigurieren, dass auf der Console auch ein lesbares Zeitformat benutzt wird?

Viele Grüße
Detlef Paschke
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,956
814
163
33
Vienna
Es wird auf der Console also nur der UNIX-Timestamp angegeben, in den Logdateien auch eine "lesbare" Zeit.
nur zur info, die zeiten in den kernel logs sind keine unix timestamps, sondern sekunden seit dem boot

Lässt sich irgendwo Konfigurieren, dass auf der Console auch ein lesbares Zeitformat benutzt wird?
nein das ist fix so im kernel
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!