[SOLVED] PVE5 fix those "Predictable Network Interface Names"

vmanz

Renowned Member
Sep 15, 2010
36
4
73
Dear Community,

Running in trouble with those new "predictable network interface names" I tried nearly everything (that I found) to get them "predictable" to my needs/understandings.

My hardware zoo did what never should even happen to the device names like swapping the onboard NIC eno1 (if I remember right) to a 10GB-plug-in-adapter. Shure things happened before in PVE4 if the MAC of the Plug-in-Card was minor to the MAC of the onboard NIC, but this was quick and easily fixed in /etc/udev/rules.d/70-persistent-net.rules ... this was controlable.

At the moment it seems "working for me" to nail it down the carpenters way via

edit /etc/default/grub and change line according to

Code:
GRUB_CMDLINE_LINUX="root=ZFS=rpool/ROOT/pve-1 boot=zfs net.ifnames=0 biosdevname=0"

then edit /etc/systemd/network/10-eth0.link
Code:
[Match]
MACAddress=a1:b1:c1:d1:e1:f1

[Link]
Name=eth0

and further /etc/systemd/network/10-eth1.link

Code:
[Match]
MACAddress=a2:b2:c2:d2:e2:f2
 
[Link]
Name=eth1

... and so on, to get it working for me

Besides there are sometimes even "renamed" devices on
Code:
ip addr show
solved by another reboot.

Courios about some of yours are handling this "innovation"

Greets,
vmanz
 
to get them "predictable" to my needs/understandings.

Are you talking about the VMs or the hosts? For "real" hosts, they are totally clear and matched every time to the real labels on the board and in the manual (at least for Fujitsu RX server I tried).
 
Hi Oliver,

Thank you for confirming my troubles and to share your
solution. I'm glad, someone tells me, that I am not the only one. Even other member of our community stumble around this item (https://forum.proxmox.com/threads/keine-netzwerkverbindung-mehr.37186/#post-182803)

My ressource to solve this trouble based on e.g.:
https://forum.proxmox.com/threads/network-interfaces-renamed-on-every-reboot.28179/
https://forum.proxmox.com/threads/p...ystemd-breaks-vlan-tagging.28539/#post-143570
https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/
https://www.freedesktop.org/software/systemd/man/systemd.link.html
https://0010100.net/blog/?x=entry:entry170723-085401

In the last link at the very near of the end is mentioned to run 'update-initramfs -u'. I didn`t pay attention to this but after watching youtube (#zfsrocks - virtualization with Proxmox and ZFS that backups itself!) I now unterstand it would be necessary to update the initram-fs if you are running your system on top of ZFS-filesystem (or a similar constellation, where the kernel needs modules to be able to mount the root-fs).

Retrospective this was the reason for writing this post. Because after poking around at the /etc/default/grub it suddenly worked, but I didn`t exaclty why. Afterwards I can explain it to myself, that on the side of this stumbling in the fog I did a system update, where the kernel was updated and so the initram-fs was newly generated, too.


Code:
[if system is based on ZFS rpool]
update-initramfs -u

now I am looking forward to get my system "predictable".

Thanks,

vmanz
 
Last edited:
  • Like
Reactions: majorgear

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!